character entities in title attribute not displayed correctly

VERIFIED DUPLICATE of bug 67127

Status

VERIFIED DUPLICATE of bug 67127
17 years ago
14 years ago

People

(Reporter: wolf-dietrich.moeller, Assigned: law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.7+) Gecko/20020107
BuildID:    2002010703

Some character entities are displayed as thick vertical bar in the tooltip
hovering over images (title attribute of src element). The same characters are
displayed correctly in normal text.
It seems that only the character entities which correspond to
WIN-1252-characters in the range 0x80 to 0x9f are affected.

Reproducible: Always
Steps to Reproduce:
1.put title attribut to any image (cf. example below)
2.hover with mouse over image to show text in tooltip
3.

Actual Results:  Some characters displayed as thick vertical bar. Only "
and © are displayed correctly in this example.

Expected Results:  Correct display of all characters

sample html-code:
<IMG src="probe.png" title="&quot;&hellip;&#8230;&bull; &trade;&copy;">

This happens with <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
and without doctype.

(Nav 4.78 at least displayed &#8230; correctly, as expected).
See also bug 67127.
Whiteboard: DUPEME?
(Reporter)

Comment 2

17 years ago
Sorry, last sentence of bug report is wrong (Nav 4.78 only displays alt
attribute, not title).

Comment 4

17 years ago
->law
Assignee: trudelle → law
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.