Closed Bug 1199169 Opened 4 years ago Closed 4 years ago

canvas 2d context arc method 100% CPU usage

Categories

(Core :: Canvas: 2D, defect, critical)

40 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1187210

People

(Reporter: abbGZcvu_bugzilla.mozilla.org, Unassigned)

Details

(Keywords: hang, testcase)

Attachments

(1 file)

Attached file repro.html
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

<body onload=document.createElement("canvas").getContext("2d").arc(0,0,1,4.4647612e+18,1)>


Actual results:

100% CPU usage


Expected results:

Instantanious execution, no further CPU usage
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
20150827030213

I can reproduce this in Firefox 40.0.2 but not the latest Nightly.
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Untriaged → Canvas: 2D
Keywords: hang, testcase
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1187210
You need to log in before you can comment on or make changes to this bug.