If New Tab button isn't placed right after tabs, it causes tabs overflow for a moment when you open/close tabs (if tabs take full length of toolbar)

RESOLVED DUPLICATE of bug 648789

Status

()

RESOLVED DUPLICATE of bug 648789
3 years ago
3 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected, firefox41 affected, firefox42 affected, firefox43 affected, firefox-esr38 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8653485 [details]
It causes tabs overflow for a moment even if there's enough space.webm

STR:   (Win7_64bit, Nightly 43.0a1 32bit   ID 20150826030211, new profile)
1. Enter customize mode, place "New Tab" button NOT right after the tabs. E.g. after "all tabs" dropmarker, or before tabs.
2. Open some new tabs so that they tool all free space in TabsToolbar
3. Press Ctrl+T/click "New Tab" button   several times.

Result:       [video] For a moment, you can see tabs overflow, even thought there's enough space
Expectations: No overflow, just like when New Tab button is placed right after the tabs.

Comment 1

3 years ago
Is this a duplicate of bug 648789?
Component: Toolbars and Customization → Tabbed Browser
(Reporter)

Comment 2

3 years ago
Yes
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648789
(Reporter)

Updated

3 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.