e10s makes Firefox crash with particular privacy preferences

RESOLVED DUPLICATE of bug 1185734

Status

()

Core
IPC
--
critical
RESOLVED DUPLICATE of bug 1185734
2 years ago
2 years ago

People

(Reporter: gael.blaise, Unassigned)

Tracking

({crash})

42 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(e10s?)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8653556 [details]
Bug Firefox.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

When Electrolysis is enabled with particular privacy preferences, eg:
  - cookies accepted,
  - third party cookies refused (don't think it as a real influence, but I precise !)
  - conservation: keep until MUST BE "ask me everytime".
Then go to a new site where you do not have any cookie and wait for the pop-up that will ask you what to do with.
NB: You have to go to a site where you don't have any cookie in your exception list, and more cookie the site sends, better it is for this demonstration


Actual results:

Firefox Developer Edition crashes, not just the actual tab, but all the browser


Expected results:

See the pop-up that asks what to do with the cookies
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Severity: normal → major
Flags: needinfo?(g.maone)

Comment 1

2 years ago
I managed to reproduce it on the 20150824 Nightly build ( https://crash-stats.mozilla.com/report/index/2093b19e-40d9-4ef7-9d85-ad7f32150827 ), but I cannot reproduce on today's builds (20150827), neither on Central nor DE.

The strangest thing is that when I then retried with previous builds (20150826 back to 20150823), both Central and DE, to find out when it could be accidentally fixed, I could not reproduce anymore ?:/

Can you still reproduce after upgrading to latest build?
Flags: needinfo?(g.maone) → needinfo?(gael.blaise)
(Reporter)

Comment 2

2 years ago
It happened again today with imgur.com (exact link if it can help: http://imgur.com/gallery/bl6HPR7
) on build "42.0a2 (2015-08-29)" (Dev Edition)
I have register the crash log, and I'll attach it to the bug, when I will finally find how to do it (I hope it will help) !

But, yes, it does not happen every time now, it makes more and more rare, but still happen sometimes.

(In reply to Giorgio Maone from comment #1)
> I managed to reproduce it on the 20150824 Nightly build (
> https://crash-stats.mozilla.com/report/index/2093b19e-40d9-4ef7-9d85-
> ad7f32150827 ), but I cannot reproduce on today's builds (20150827), neither
> on Central nor DE.
> 
> The strangest thing is that when I then retried with previous builds
> (20150826 back to 20150823), both Central and DE, to find out when it could
> be accidentally fixed, I could not reproduce anymore ?:/
> 
> Can you still reproduce after upgrading to latest build?
Flags: needinfo?(gael.blaise)
(Reporter)

Comment 3

2 years ago
Created attachment 8654777 [details]
Firefox Crash Message.txt

This is the log of the latest crash that happened on my computer

Comment 4

2 years ago
I crashed with the latest Nightly, but it's hard to reproduce.
https://crash-stats.mozilla.com/report/index/17708446-3d55-4822-b167-752802150831
The crash occured when I was browsing another tab while a permission cookie pop-up appeared from the other tab.

Maybe we need to find accurate STR.
Blocks: 516752
Severity: major → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::MessageChannel::DebugAbort(char const*, int, char const*, char const*, bool) | mozilla::ipc::MessageChannel::~MessageChannel() | mozilla::dom::ContentParent::cycleCollection::Dele…
Ever confirmed: true
Keywords: crash

Comment 5

2 years ago
I found STR and I think this bug is a dupe of bug 1185734.
Could you test my STR here: https://bugzilla.mozilla.org/show_bug.cgi?id=1185734#c1
Flags: needinfo?(gael.blaise)
(In reply to Loic from comment #5)
> I found STR and I think this bug is a dupe of bug 1185734.
> Could you test my STR here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1185734#c1

Why do you think this is a dupe? This is crashing on a different IPC_ASSERT:
    IPC_ASSERT(mCxxStackFrames.empty(), "mismatched CxxStackFrame ctor/dtors");

Oh, I see, comment 1 here has a crash that looks like the other bug.
Component: Untriaged → IPC
Product: Firefox → Core
tracking-e10s: --- → ?
(Reporter)

Comment 7

2 years ago
(In reply to Loic from comment #5)
> I found STR and I think this bug is a dupe of bug 1185734.
> Could you test my STR here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1185734#c1

Yes, I think this is well a dupe of the other bug 1185734.
The only thing changing with your steps is that in my case, I don't even need to go back to the OS desktop before the crash, just have to wait. And after opening the link, it just freezes and then crashes !
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(gael.blaise)
Resolution: --- → DUPLICATE
Duplicate of bug: 1185734

Comment 8

2 years ago
(In reply to Andrew McCreight [:mccr8] from comment #6)
> (In reply to Loic from comment #5)
> > I found STR and I think this bug is a dupe of bug 1185734.
> > Could you test my STR here:
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1185734#c1
> 
> Why do you think this is a dupe? This is crashing on a different IPC_ASSERT:
>     IPC_ASSERT(mCxxStackFrames.empty(), "mismatched CxxStackFrame
> ctor/dtors");
> 
> Oh, I see, comment 1 here has a crash that looks like the other bug.

Yes, maybe I'm wrong. Indeed, I thought it was a dupe because when finding STR for this bug, I crashed with the same signature as bug 1185734.
You need to log in before you can comment on or make changes to this bug.