Lightweight themes make it look like toolbars have greater height in normal window mode

RESOLVED DUPLICATE of bug 1111138

Status

()

Firefox
Theme
--
minor
RESOLVED DUPLICATE of bug 1111138
3 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox40 affected, firefox41 affected, firefox42 affected, firefox43 affected, firefox-esr38 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8653635 [details]
#navigator-toolbox changing height.webm

STR:   (Win7_64bit, Nightly 43.0a1 32bit   ID 20150827030213, new profile)
1. Switch Firefox window to "normal" mode, e.g. dock to left side of screen
2. Enter Customization mode
3. Click "Themes", hover mouse over any lightweight theme

Result:       After Step 3 the height of #navigator-toolbox increased
Expectations: #navigator-toolbox should have same width with default and lightweight themes

Fx 31 if unaffected, 32 is affected. Don't know about ESR31.
I expect this is caused by the top border we set on glass windows for lightweight themes.

However, those are on the #browser-panel... how sure are you the toolbox itself is changing height here, rather than it looking that way because the container (#browser-panel) gets a border?
Flags: needinfo?(arni2033)
Comment hidden (obsolete)
(Reporter)

Comment 3

3 years ago
I'm not sure at all, I just described the symptoms, didn't actually debug this.
Please edit the title if needed, because sometimes I can't describe simple thing in English.
> Result:       Looks like after Step 3 the height of toolbars increased
> Expectations: Toolbars should have same *height(visually) with default and lightweight themes
(In reply to arni2033 from comment #3)
> I'm not sure at all, I just described the symptoms, didn't actually debug
> this.
> Please edit the title if needed, because sometimes I can't describe simple
> thing in English.

That's fine, I was just trying to clarify. I can see the problem, I was just wondering if my diagnosis of it was wrong because you specifically called out #navigator-toolbox

I've confirmed that this is due to the top border on #browser-panel.
(Reporter)

Updated

3 years ago
Blocks: 591930
Just realized this is a dupe of 1111138 which I'm mentoring (and have been for a while). Oops!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1111138
(Reporter)

Updated

2 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.