HTML Validator ext on AMO shows as not signed on restart.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

The HTML Validator on AMO: https://addons.mozilla.org/en-US/firefox/addon/html-validator/ which implies it is signed is not able to be verified like it's not signed when restarting Firefox.


Actual results:

After restart, get the warning that it could not verified.


Expected results:

Comes back with no warning.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

3 years ago
I'm having the same problem with HTML Validator 0.9.5.8.1-signed. Almost every time I restart Firefox 43.0b1, it says some of my addons couldn't be verified and HTML Validator is disabled. I then have to reinstall it and restart to get HTML Validator back.

Could someone please fix this?

Comment 3

3 years ago
Sometimes when I try to reinstall HTML Validator 0.9.5.8.1-signed, it says it failed because it couldn't update the required file.
One possible cause for this may be if the validator add-on modifies files inside it's own extension directory.

This is no longer valid with add-on signing, files must be kept as-is from the time of signature.  If this is being done, the add-on should change to modify files somewhere else instead.
(Reporter)

Comment 5

3 years ago
FYI, version 0.9.6.3 has the same behavior. One first restart after updating, there is no warning. One next restart, it has a warning. I did change one of it's options before the 2nd restart.

Comment 6

3 years ago
I had the same problem as MarkRH with 0.9.6.3.

Comment 7

3 years ago
Hi JRyans,

I am the dev of HTML Validator extension. 
What the extension does is to remove a new_install.txt file in the extension directory after the 1rst restart. This is one way to detect a new installation. 

What I can do is to replace this file with a preference. But I have no way to test this. Since I can not sign the extension... ?  I can submit a new version to AMO. Without having any idea if it will fix the issue or not ?

What do you propose ?

Thanks
I am not sure of a good way to test that the signature will be preserved before submitting to AMO.  The only thing I can think of is something like:

1. Unzip the fixed version of the add-on into a sample directory
2. Install the fixed version into a profile and quit Firefox
3. Diff the sample directory and installed extension directory
4. If there are any changes, it's like the signature check will fail

:kmag, can you think of a better way to test?
Flags: needinfo?(kmaglione+bmo)
Yeah, that's about the best you can do. I'd recommend comparing lists of checksums rather than using a diff tool, though.
Flags: needinfo?(kmaglione+bmo)

Comment 10

3 years ago
It is a quite easy fix. I have have remove the "new_install.txt" file usage and replaced it by a preference. Do you think that I should resubmit the extension and pray that it gets fixed :) ? 

I guess yes.

Thanks,
If you're fairly certain that's the only place you're making changes, then yes, that sounds like a good idea

Comment 12

3 years ago
Just a quick question, does anyone know the time table for HTML Validator 0.9.6.4 get signed for Beta and Release users? Thank you.

Comment 13

3 years ago
The version 0.9.6.4 was approved yesterday. It works for me.
So, it was really the remove of the "new_install.txt" after a start that was causing this.

Thanks for your help.
Thanks for checking, glad it works now. Since this is not a Firefox bug per se, I'm marking this bug WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

3 years ago
Just confirming as the one that started this that 0.9.6.4 stays showing as validated on subsequent restarts. Yay :) Thanks for getting this to work.

Comment 16

3 years ago
Just got the 0.9.6.4 and it stays validated for me as well. Thank you for fixing this.
You need to log in before you can comment on or make changes to this bug.