[traceback] TypeError: argument of type 'NoneType' is not iterable

VERIFIED DUPLICATE of bug 1198981

Status

Socorro Graveyard
Middleware
VERIFIED DUPLICATE of bug 1198981
3 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
Errormill: 

STR:

Load https://crash-stats.mozilla.com/search/results/?product=Firefox&version=ALL%3AALL&range_value=2&range_unit=weeks&date=10%2F18%2F2014+05%3A00%3A00&query_search=signature&query_type=contains&query=libavcodec.so&reason=&release_channels=&build_id=&process_type=any&hang_type=any

Actual Results:

TypeError: argument of type 'NoneType' is not iterable

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "ratelimit/decorators.py", line 30, in _wrapped
    return fn(*args, **kw)
  File "crashstats/supersearch/views.py", line 213, in search_results
    search_results = api.get(**params)
  File "crashstats/supersearch/models.py", line 175, in get
    return super(SuperSearch, self).get(**kwargs)
  File "crashstats/crashstats/models.py", line 564, in get
    return self._get(expect_json=expect_json, **kwargs)
  File "crashstats/crashstats/models.py", line 633, in _get
    expect_json=expect_json,
  File "crashstats/crashstats/models.py", line 156, in inner
    result = method(*args, **kwargs)
  File "crashstats/crashstats/models.py", line 501, in fetch
    result = implementation_method(**params)
  File "socorro/external/es/supersearch.py", line 200, in get
    params = self.get_parameters(**kwargs)
  File "socorro/lib/search_common.py", line 224, in get_parameters
    self.fix_date_parameter(parameters)
  File "socorro/lib/search_common.py", line 261, in fix_date_parameter
    '<' in param.operator and (
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1198981
(Reporter)

Comment 2

3 years ago
Verified dupe; thanks
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.