Closed Bug 1199429 Opened 6 years ago Closed 6 years ago

[gatt] make test-integration fails to start b2g on os x

Categories

(Testing Graveyard :: JSMarionette, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aus, Assigned: aus)

References

Details

(Keywords: regression)

Attachments

(4 files)

make test-integration fails to start b2g as expected on os x. works fine on linux. this will get fixed asap as we have many devs on os x.
No longer blocks: 1196425
Trying to run b2g-desktop on its own on Mac OS X results in the following:

Couldn't load XPCOM.
Blocks: 1189286
Blocks: 1187717
I've been exploring this issue and replacing b2g-desktop with a manually downloaded copy of Mulet and renaming firefox-bin to b2g-bin works great. I know :gerard-majax has a pull request ready to use Mulet instead in gaia. Let's land it. It's the future anyway. :)

The only issues there are intermittent issues with Gij 38 and Gij 39. I have a pull request for these that seems to work much better (+ fixes to logging for debugging).

I'll land these ahead of time and we can then switch over to using Mulet.

Since :gerard-majax is in a different timezone, I'll dust off his pull request (if need be) and land it today.
Commit (gaia-master): https://github.com/mozilla-b2g/gaia/commit/245f4fb926b15c6a4bc53a1dd0c1506ab5a1a38c

Once this commit is bumped over to b2g-inbound. I will be able to see if we've resolved the intermittent issues with Gij38 and Gij39 for good.

Afterwards, we'll re-enable visibility for these on Treeherder and switch gaia to use Mulet to run Gij locally and on Taskcluster.
Commit (gaia-master) https://github.com/mozilla-b2g/gaia/commit/0a552a2157559fdba67a25421ea94eff38bce593

This switches us over to using Mulet instead of b2g-desktop for all platforms and all tests.

\o/
Blocks: 1194979
Blocks: 1199348
This is now fixed. One can run make test-integration without any issues on Mac. Or Linux. And we're using Mulet instead of b2g-desktop. Sweet!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
See Also: → 1205118
Hi Aus, GijTV seems to permanently fail since this patch landed. Could you please have a look? Thank you!
Flags: needinfo?(aus)
(In reply to yifan [:yifan][:yliao] from comment #10)
> Hi Aus, GijTV seems to permanently fail since this patch landed. Could you
> please have a look? Thank you!

Yes, I filed a bug specifically for this (which I think you found already) :)
Flags: needinfo?(aus)
Not sure how/where to file a bug, but currently https://nightly.mozilla.org/ still has Desktop Boot2Gecko and points to Firefox Desktop links.
I can find b2g desktop builds still at:
https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
But those are broken for Mac at least.

Since Mulet is apparently the preferred platform for B2G desktop testing, perhaps we could get Mulet nightly builds?
(In reply to Martijn Wargers [:mwargers] (QA) from comment #12)
> Not sure how/where to file a bug, but currently https://nightly.mozilla.org/
> still has Desktop Boot2Gecko and points to Firefox Desktop links.
> I can find b2g desktop builds still at:
> https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
> But those are broken for Mac at least.

What's broken about them?

> Since Mulet is apparently the preferred platform for B2G desktop testing,
> perhaps we could get Mulet nightly builds?

They are now available in TaskCluster:

https://tools.taskcluster.net/index/artifacts/#gecko.v2.mozilla-central.latest.b2g/gecko.v2.mozilla-central.latest.b2g.macosx64-mulet-opt
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.