Messages not read for many hours in spite of 5 minute setting

RESOLVED DUPLICATE of bug 1196662

Status

RESOLVED DUPLICATE of bug 1196662
3 years ago
3 years ago

People

(Reporter: t20, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

1. Let TB run for hours.
2. Note that no messages have been received.
3. Click on "Get Messages" button, main part.



Actual results:

4. Note new messages are received, some several hours old.


Expected results:

The new messages should have been displayed in the Inbox within 5 minutes of being received.

----

Environment: TB version 38.2.0 (the latest that was automatically installed). Windows 8. Firefox 40.0.2.

Note: workaround is to click "Get Messages" often.

Note: my preferences may very well be set up incorrectly. Although I have tried my best, the Accounts area of TB seems very complicated and hard to understand, even for a software engineer with 40 years of experience. Perhaps I have the Server setting "Check for new messages every 5 minutes" setting somehow for the wrong account. I use many accounts and identities in an attempt to handle many server-side forwarders. I apologize in advance if this proves not to be a bug in TB.

Note: this problem may not be in the Preferences area as I stated, but I could not find a TB area that seemed related to reading incoming emails on schedule.
(Reporter)

Comment 1

3 years ago
Maybe the problem only happens when Thunderbird is first run. Apparently, there is no way to get TB to read messages when it is first run, and it will not repeatedly read messages until it first reads messages manually, by clicking the Get Messages button?

Sometimes it reads messages automatically, sometimes it doesn't.

Am I the only one reporting this bug? Is it really a bug> Is anyone there, maintaining TB?
(Reporter)

Comment 2

3 years ago
Okay, sorry I didn't notice this more carefully: the problem happens after I put my Windows 8 laptop computer into standby by closing its lid for the night. The next morning, after opening the lid, the computer resumes without problem BUT TB DOES NOT READ THE EMAILS WAITING ON THE SERVER. I have to click Get Messages to read these first messages of the day, some of which can be waiting for many hours.

There seems to be no TB option to make TB read messages after such a large time interval when the computer comes out of standby.
(Reporter)

Comment 3

3 years ago
I found the following excellent description of this bug on the Web from December 2009. 2009!

"I have a similar problem - in Thunderbird 3, I have "Check for new messages at startup" and "automatically download new messages" checked but nothing happens until I do a manual download. After that, Thunderbird does regularly check for new messages and downloads them but the interval seems to be erratic - not the "every 5 minutes" that I have checked."

This is exactly what I observe in 2015 with version 38.2.0 .

Connection Security is STARTTLS, Server Name is the IP address of my CPanel Linux mailserver. I also have "include this server when getting new mail" checked in the Advanced Account Settings.

How about getting this bug fixed now?

Maybe the bug is in an Add On. Is there a way to stop add ons from being loaded?

My add ons: 
Border Colors GT
Clost tab on esc
quicktext
rise of the tools
search as list
toggle word wrap

In 2010 the following was posted at http://forums.mozillazine.org/viewtopic.php?f=39&t=1632695:

"Now I am thoroughly confused - without making any changes at all to Thunderbird 3, it has suddenly decided to check for new emails on startup. All on its own. What very strange software. Please help me to go back to Thunderbird 2."

There are other interesting postings there, too.

Comment 4

3 years ago
This is being addressed in bug 1196662. You can follow the action there
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196662
(Reporter)

Comment 5

3 years ago
I do not agree that this bug I have reported is a duplicate of a bug concerning hibernation, as I never hibernate my computer (I only put it in and out of standby and restart it).

Further, I do not agree to a series of bug fixing steps, as described at that other bug report.

This failure of TB to refresh/reload the server's outgoing email list is clearly a genuine bug of very long standing, affecting nearly all users, that should get fixed without further delay.

I think I have provided sufficient information, and the evidence of other people who have observed this same bug and posted complaints on the Web for many years now. I consider this bug a serious one, and worthy of being fixed now.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

3 years ago
It sounds like "Sometimes it reads messages automatically, sometimes it doesn't." is a more comprehensive summary of your issue. Is that correct?

> This failure of TB to refresh/reload the server's outgoing email list is clearly a genuine bug of very long standing, affecting nearly all users,

If this affects all users please educate us by citing a few of the URLs many *recent* URLs which state this problem (that are not related to hibernate)
Flags: needinfo?(t20)
(Reporter)

Comment 7

3 years ago
Yes, sometimes TB reads messages automatically, as instructed in its options, but even then it can read some messages hours after they were received by the server. Read all of my comments here for a more complete statement of this bug. There is no simple summary statement because there are a variety of related failures in reading incoming email reported here.

I am not sure if these failures happen for all users, happen intermittently for all users, or happen only for some users. A skilled developer should be able to examine the source code and, with the help of an automated test that reproduces the problem or a way to simulate incoming messages sent at a simulated earlier time, discover where the problem is and try fixing it. I'll be happy to alpha-test any proposed fix in my environment.

As to URLs, you can start with the URL I already gave above, http://forums.mozillazine.org/viewtopic.php?f=39&t=1632695 . It contains several pages of complaints by TB users that do not mention the use of hibernation.

If you would like to read even more complaints, please do some Web searching and I feel sure you can find some. It may take some creativity in picking search terms, as various keywords are used to describe this family of problems with TB and distinguish them from many other bugs in TB, such as in displaying messages in panes properly, reading the options and account settings properly, etc.

On the other hand, if this bug is caused by an interaction with the use of Firefox, or with something in the operating system, or with local or server customization, then it is possible that these bugs bother only a few TB users.

That the bugs affect many TB users is just a speculation on my part. We will see if it is true when someone actually tries to fix the bug. I'm not sure there are sufficient numbers of qualified current TB developers for one of them to notice this bug report and be inspired to look at and play with the code.
Flags: needinfo?(t20)
(Reporter)

Comment 8

3 years ago
Perhaps there is a command-line or other TB option to record detailed debug tracing output? Perhaps I could enable it to perhaps reveal why messages are not read when the computer resumes from standby, or when the refresh interval has expired.

Comment 9

3 years ago
One can appreciate your attempt to provide as much information as possible, but...
A. please do not speculate, facts speak louder
B. the URL you cite is  6 years old - old issues are not relevant
C. please don't pull the "A skilled developer should be able to examine the source code" card unless you have unlimited source of programmer resource. Issues are best fixed with narrowly scoped information which allows someone to reproduce the problem.
D. most of the volunteers working on Thunderbird bugs are not programmers, but we are most often that ones who determine whether a report is a legitimate bug, thus...

The first two questions you are:
1. when did your problem first start?  precision is appreciated
2. does the problem occur if you have started Thunderbird in safe mode? http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode

But now I read you're earlier comment "the problem happens after I put my Windows 8 laptop computer into standby by closing its lid for the night."  This standby mode is like hibernate. THIS is why I marked your bug report as a duplicate. So if your statement is accurate and the behavior started within the last two weeks when using version 38.2.0, then you can forget the other questions.
Flags: needinfo?(t20)
(Reporter)

Comment 10

3 years ago
Thank you for your kind corrections. I will try to contribute only in the ways you have indicated. Too bad I can't edit my previous postings here.

As to the URL being 6 years old, it is relevant if the bugs reported there have not been fixed. It is not relevant if those reports are for bugs with identical behavior that had been previously fixed but are now manifesting again for new reasons. I cannot agree with a flat-out "old issues are not relevant". They may indeed still be relevant, if there are bugs that have not been fixed in 6 years. We will see if they are relevant when the current bugs are found and fixed.

As to when the problem started, it seems to me that it got worse just about one to three weeks ago. I don't remember having to manually request a refresh before that time, or seeing emails that were sent many hours ago. But I'm not certain, as my memory is poor. I don't know how to apply precision here, since the problem happens in the moment and leaves no trace anywhere.

I would rather not run Windows in safe mode because under XP doing that caused the Desktop to lose the positioning of each icon. Even though I now use Windows 8, I don't want to risk losing that information. Please ask another user of TB who has the same problems to do that.

Is there a way to run TB without running addons? I don't want to bother disabling each one. I'd like to see if running without addons fixes the problem.

Yes, one of the family of bugs reported here is failure to read messages after startup from standby mode, and I can understand if you call that hibernation because it has similarities to hibernation. But there are other bugs that I've reported here that clearly have nothing to do with startup from standby.

If you want to put effort into it, feel free to clean this report up and create several separate reports in its place. Me, I don't have time for that, sorry. I apologize for putting several related bug reports together in this one report.

Thanks for all the work you are putting into this. It is appreciated.
Flags: needinfo?(t20)

Comment 11

3 years ago
(In reply to David Spector from comment #10)
> Thank you for your kind corrections. I will try to contribute only in the
> ways you have indicated. Too bad I can't edit my previous postings here.
> 
> As to the URL being 6 years old, it is relevant if the bugs reported there
> have not been fixed. It is not relevant if those reports are for bugs with
> identical behavior that had been previously fixed but are now manifesting
> again for new reasons. I cannot agree with a flat-out "old issues are not
> relevant". They may indeed still be relevant, if there are bugs that have
> not been fixed in 6 years. We will see if they are relevant when the current
> bugs are found and fixed.

Yes, I rather simplified that statement. Add the word "unconfirmed" and you get closer to my meaning. Reports on the web and in web forums which don't reference bug reports or are not confirmed by the the support personnel often aren't worth reading.


> As to when the problem started, it seems to me that it got worse just about
> one to three weeks ago. I don't remember having to manually request a
> refresh before that time, or seeing emails that were sent many hours ago.
> But I'm not certain, as my memory is poor. I don't know how to apply
> precision here, since the problem happens in the moment and leaves no trace
> anywhere.

That puts us in the territory of bug 1196662.
 
> I would rather not run Windows in safe mode because under XP doing that
> caused the Desktop to lose the positioning of each icon. Even though I now
> use Windows 8, I don't want to risk losing that information. Please ask
> another user of TB who has the same problems to do that.

You don't lose it. You still have the settings, it's just supressed for that startup. 
(and we are only concerned here with defining your problem - other people can't define your problem without running *your* environment) 

> Is there a way to run TB without running addons? I don't want to bother
> disabling each one. I'd like to see if running without addons fixes the
> problem.

Thunderbird safe mode. You can find it documented at https://support.mozilla.org/products/thunderbird
 
> Yes, one of the family of bugs reported here is failure to read messages
> after startup from standby mode, and I can understand if you call that
> hibernation because it has similarities to hibernation. But there are other
> bugs that I've reported here that clearly have nothing to do with startup
> from standby.
> 
> If you want to put effort into it, feel free to clean this report up and
> create several separate reports in its place. Me, I don't have time for
> that, sorry. I apologize for putting several related bug reports together in
> this one report.

The practice in bugzilla is for reporter to file one issue per bug. The main issue here is 1196662.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196662
You need to log in before you can comment on or make changes to this bug.