Autocomplete matches should list collected addresses last.

VERIFIED WORKSFORME

Status

P2
normal
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: ewv, Assigned: racham)

Tracking

Trunk
mozilla1.2alpha

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
 
(Reporter)

Comment 1

17 years ago
From n.p.m.mailnews thread 

Bruce Mallet wrote:

I've been using Mozilla 0.9.7 recently full time for email but found
myself twice embarrased by the autocomplete feature of addressing. Here is how:

I've an address book setup for a client company.  Some mail I've
received from people in the client company contains a lot of "CC'd"
addresses of people within that company.  These all end up in my
"Collected Addresses" book.  Not only is there one, but there are
*three* names among them that either match or are extremely close
matches for friends of mine.

So I send a note to one of these friends.  Autocomplete finds the name
in "Collected Addresses" rather than in my "Friends" address book.  I
hit send.  Whoops.

I can find no way to exclude a given address book from the
autocomplete search (is there a way?).  Theorizing (hoping?) that
perhaps the autocomplete search is in the order that the address books
appear in the window I've tried to figure out how to reorder them. But I've not
been successful.


--------------------------------------

It would be very nice if the first matches came out of the real address book and
additional matches came out of the collected addresses. It would save typing,
not just embarassment.

Comment 2

17 years ago
*** Bug 119951 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
This is a major annoyance for me. 

IMPORTANT: A collected address should never be a default choice!!
Keywords: nsCatFood
OS: Linux → All
Hardware: PC → All

Comment 4

17 years ago
Marking nsbeta1 because it is a reasonable expectation.
Keywords: nsbeta1

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
Discussed in Mail News bug meeting.  Decision was to minus and move to 1.2.
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2

Comment 6

17 years ago
Trunk build 2002-07-09: WinMe, Linux RH 7.1
Marking Worksforme. My Personal address book entries appear before the collected
address book entries while autocompeting.

Does anyone else still see this problem?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Branch build 2002-07-16: WinMe, Mac 10.1.3
Branch build 2002-07-17: Linux RH 7.1
Verified Worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.