Improvement: Selection of addressbook

RESOLVED DUPLICATE of bug 1142705

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 1142705
3 years ago
3 years ago

People

(Reporter: Leopoldo Saggin, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

This is not a real bug, the request of an improvement to apply to addressbook(s).
I have many addressbooks and many mailing lists.
The "new" approach to go select "all" addressook by default is good, but have some drawback if you need to use the same addressbook more than once.
Each time you need to reselect it. So my suggestion is that if you select one addressbook, especially in the sidebar of the composition window, the the last selected stays there.
So if you need to send anothe message at someone/some list inside the same addresskbook, then you do not need to reselect again. If you need to search for someone/some list everywere you can move to "All", if you need to select someone/some list in another addressbook, you just need to select the one you need. IMHO it seems a better and more rational approach
Regards
Topoldo



Expected results:

What I report is not a real bug, but the request of a change to apply to the behaviour of addressbook(s).
I have many addressbooks and many mailing lists in each addressbook I need to send mail in sequence.
The "new" approach to addressbooks (TB >= 38.x) ie the select "all" addressook by default is good, but have some drawback if you need to use the same addressbook more than once as I need.
Each time I need to send something to some list of an addressbook I need to reselect the addressbook I need.
So my suggestion is one selects an addressbook (especially in the case of sidebar of the composition window), the last selected should stay selected.
This way, if you need to send another message at someone/some list inside the same addresskbook, then you do not need to reselect the relative addressbook again.
If you need to search for or send to someone/some list everywhere inside your contacts, then you can move to "All"; if you need to search for or send to someone/some list in another addressbook, then you just need to select the addressbook you need.
IMHO it seems a better and more rational approach to the addressbook manageing.

Regards,
Topoldo
Yes, Topoldo, we're already in the process of implementing that in bug 1142705.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142705
You need to log in before you can comment on or make changes to this bug.