Closed Bug 1199756 Opened 6 years ago Closed 6 years ago

[Window Mgmt] Sharing two pictures to a SMS from Gallery causes the device to reboot

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: KTucker, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark][2.5-aries-test-run-2])

Attachments

(1 file)

When the user opens up gallery, selects two pictures, taps the share icon and then taps messages, the phone will reboot.

Repro Steps:
1) Update a Aries to 20150828140025
2) Tap on Gallery.
3) Tap on the "Box" icon to multi-select pictures.
4) Select two or more pictures and tap on the "Share" icon.
5) Tap on "Messages" and observe.

Actual:
The phone will go to a black screen and then reboot.

Expected:
The phone does not reboot and the user can share multiple images through a message without issue. 

Environmental Variables:
Device: Aries 2.5
Build ID: 20150828140025
Gaia: fa15462b29258fdec8329bfc367e590022dbc9e5
Gecko: 008d4d76f387b722fbee151e1c9e1501482054e5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 5/5 100%
See attached: video clip, logcat
[Blocking Requested - why for this release]:

This issue also occurs on Flame 2.5

The screen goes black and the phone restarts when trying to share 2 or more pictures from gallery.

Environmental Variables:
Device: Flame 2.5 (Full Flash)(KK)(319mb)
Build ID: 20150828030207
Gaia: b69c16798ddd7154207f56d983721a327522f5d1
Gecko: 87e23922be375985d0b1906ed5ba5f095f323a38
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


This issue does not occur on Flame 2.2

The user can share two or more pictures from gallery to a SMS without issue. 

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
Build ID: 20150828032506
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 16d864d163de
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-v4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Whiteboard: [2.5-Daily-Testing][Spark]
QA Contact: mshuman
This issue appears to be caused by:
Bug 1186307 - Unify the StructuredCloneCallbacks in WorkerPrivate.cpp

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150827085935
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: d8bef3a664a7020437275c547b5f021b7a3aba1c
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150827092034
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: 0ed63658fcba416b196c8e1fc33b78b873e95883
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue DOES reproduce
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: 0ed63658fcba416b196c8e1fc33b78b873e95883

First Broken gaia / Last Working gecko - 
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: d8bef3a664a7020437275c547b5f021b7a3aba1c

Gecko Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d8bef3a664a7020437275c547b5f021b7a3aba1c&tochange=0ed63658fcba416b196c8e1fc33b78b873e95883
Blocks: 1186307
Flags: needinfo?(jmercado)
Andrea can you please take a look at this?  The changes for bug 1186307 seem to be the cause.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
I recently fixed another regression related to bug 1186307. Can you please check if this issue is fixed using m-i?
Flags: needinfo?(amarchesini)
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][2.5-aries-test-run-2]
Keywords: qawanted
This issue appears to be fixed on Aries but probably not on Flame. I say probably because on latest mozilla inbound Flame build, upon flashing complete it shows a crash report uploading prompt, indicating something crashed before it enters FTU. And if I bypass that and enters Homescreen and open Gallery it will close out and say 'something has crashed', if I bypass that again and just do the STR, the device still reboots.

Bug no longer occurs on:
Device: Aries 2.5
BuildID: 20150831182519
Gaia: 31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gecko: dff3c8b2065943a29876dc61e149719d12c0925e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Bug still occurs on:
Device: Flame 2.5 (319MB memory)
BuildID: 20150831104547
Gaia: 31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gecko: 6b264cf230a0b259cfb52c4837fc82470c1a052b
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Andrea this still seems to be occurring on Flame devices flashed to an Mozilla inbound build today per comment 6.  Can you please look into this?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
blocking-b2g: 2.5? → 2.5+
How about a non memory restricted flame?
Keywords: qawanted
I am not currently seeing this issue reproduce on the latest Flame Nightly with either 319MB or 512MB memory.
Sharing 2 or more images from Gallery to Messages will properly resize the images and place them into a new MMS draft.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150904030224
Gaia: d7385b79e68d4ad662cacf810506e9ee53345d23
Gecko: 7f987c38bd3e5ac9a834981e85378bdb02338e9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Seems like this issue is actually fixed with the change from bug 1186307.  Please reopen if this occurs again.
Status: NEW → RESOLVED
Closed: 6 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Flags: needinfo?(amarchesini)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.