selecting language setting with arrow keys loses focus

VERIFIED WONTFIX

Status

()

Core
Layout: Form Controls
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: TucsonTester3, Assigned: rods (gone))

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    2002011308
OS: WINME

selecting language setting with arrow keys loses focus
on the URL in question, if you tab to the "select language" form, and use 
arrows keys to select language preference you lose focus and the selected area

Reproducible: Always
Steps to Reproduce:
1.open NS browser window to URL: http://groups.google.com/advanced_group_search?
as_drrb=q&as_qdr=d&lr=lang_et&hl=en
2.Tab down to the line "Language      Return messages written in"
3.the window to the right will take focus
4. using the up/down arrow keys selected a different language

Actual Results:  the page refreshes and you lose focus

Expected Results:  should allow you to scroll through all language options 
before selection is complete

if you use the drop down window and the arrow keys the page will not refresh 
and you will maintain focus.
(Assignee)

Comment 1

17 years ago
It does exactly the same thing in IE 6.0. It happens because when you select a
new lang. it load a new page and the focus is reset.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
Verified since it is reloading the page, and IE 6 does the same thing.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
With build 2002021203 you can now scroll through the languages before selecting
 without the page reloading but IE 6 still acts the same.
You need to log in before you can comment on or make changes to this bug.