Closed Bug 1199807 Opened 7 years ago Closed 7 years ago

Investigate using Direct Manipulation for improved input event interaction

Categories

(Core :: Widget: Win32, defect)

Unspecified
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 890878

People

(Reporter: jrmuizel, Unassigned)

Details

Windows 8 adds Direct Manipulation. It's an API designed for asynchronous pan & zoom kinds of things.

Reading the docs hint that it might be able to get input on threads other than the ones that own the HWND, but it's not clear.

Chrome is using Direct Manipulation to get nicer events:
https://code.google.com/p/chromium/codesearch#chromium/src/ui/gfx/win/direct_manipulation.h&q=%22direct%20manipulation%22&sq=package:chromium&type=cs&l=18
I had a bit of a look at what, if any, magic Direct Manipulation uses. Here's what I found out:
- There's a InitDManipHook function that's called
- This installs ManipulationPostProcessMessage and ManipulationPreProcessMessage hooks that are called by User32.dll before dispatching messages. I'm not sure what these hooks do, or why they're needed.
Blocks: apz-desktop
Component: Panning and Zooming → Widget: Win32
OS: Unspecified → Windows 8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890878
You need to log in before you can comment on or make changes to this bug.