[Downloads] Checkboxes are close to the edge of the screen

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: AdamA, Assigned: kgrandon)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8654410 [details]
logcat

Description:
in the downloads section of the settings app when the user turns on the multi select option in the top right the checkboxes that appear are too close to the edge of the screen.

Prerequisite:
Download a file.

Repro Steps:
1) Update a Aries to 20150828140025
2) Open settings > Downloads
3) Select the multiselect option in the top right
4) Observe checkboxes

Actual:
Checkboxes are right against the edge of the screen

Expected:
It is expected that the checkboxes are not right next to the edge of the screen

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150828140025
Gaia: fa15462b29258fdec8329bfc367e590022dbc9e5
Gecko: 008d4d76f387
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8654411 [details]
Checkbox edge of screen
(Reporter)

Comment 2

3 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150828030207
Gaia: b69c16798ddd7154207f56d983721a327522f5d1
Gecko: 87e23922be37
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
Checkboxes are right against the edge of the screen
---------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
Build ID: 20150826032503
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 1effc4cb6414
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
There is room between the edge and the checkbox.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
Kevin, did you add some web-components here?
Flags: needinfo?(kevingrandon)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
We are blocked by this Bug 1194127 from getting a smaller window. 

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150808020407
Gaia: d2c91b0663f2f2e3dc28d2e1e21e8a0a654398cc
Gecko: 0d89677508b2
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150818133239
Gaia: 027aadd39bc8c186bbabb91db9b6bff671ed8c10
Gecko: d22441fc640fbd14de11c9b9f68bf9d1e881eb93
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue DOES NOT 
Gaia: d2c91b0663f2f2e3dc28d2e1e21e8a0a654398cc
Gecko: d22441fc640fbd14de11c9b9f68bf9d1e881eb93

First Broken gaia / Last Working gecko - Issue DOES reproduce (indicating a Gaia issue)
Gaia: 027aadd39bc8c186bbabb91db9b6bff671ed8c10
Gecko: 0d89677508b2

Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/d2c91b0663f2f2e3dc28d2e1e21e8a0a654398cc...027aadd39bc8c186bbabb91db9b6bff671ed8c10
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: mivanov
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
(Assignee)

Comment 5

3 years ago
I may have broken this, will take a look.
Assignee: nobody → kevingrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kevingrandon)
(Assignee)

Comment 6

3 years ago
This was most likely introduced in bug 1182670.
Created attachment 8655767 [details] [review]
[gaia] KevinGrandon:bug_1199838_download_checkbox_margin > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8655767 [details] [review]
[gaia] KevinGrandon:bug_1199838_download_checkbox_margin > mozilla-b2g:master

This is just a simple one-liner with a margin change to make it match the other checkboxes in the app. It will actually have an increased margin compared to before, but this is better because it's consistent with the other checkboxes. R=me.
Attachment #8655767 - Flags: review+
(Assignee)

Comment 9

3 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/f1ddc44b3eee1e1da8721b571c8a54ab15e7e2b8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Checkboxes are not close to the edge of the screen. 
See attachment: verified_Aries KK_v2.5.png
Reproduce rate: 0/10

Device: Flame KK 2.5 (Pass)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Version       v18D v4
Firmware Date          Sat Sep  5 18:38:03 EDT 2015

Device: Aries KK 2.5 (Pass)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-master: affected → unaffected
Created attachment 8657526 [details]
verified_Aries KK_v2.5.png
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: unaffected → verified
You need to log in before you can comment on or make changes to this bug.