If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Resizing a textarea (or element with resize attribute) inside a centered inline-block adds/subtracts from its width only half of the expected value

RESOLVED DUPLICATE of bug 1105906

Status

()

Core
Untriaged
RESOLVED DUPLICATE of bug 1105906
2 years ago
2 years ago

People

(Reporter: Fernando Gutiérrez, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8654546 [details]
Comparison between working version (chrome) and buggy (firefox)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Go to http://codepen.io/anon/pen/VvZNEG and resize the width of textarea.


Actual results:

Textarea is not resized as much as the amount you move the mouse. The more you resize, the bigger the distance between the border of textarea and the mouse cursor.

The problem is the amount being added/sustracted to its width is what would be added if it wasn't centered. Because it is, only half of that goes to each side, creating the distance between its border and the mouse.

Also, when you finish resizing, the cursor doesn't go back to default until you move the mouse.

See attachment to understand the problem better.
It's working fine in chrome 44.0.2403.157
I am using windows 10 professional.



Expected results:

Textarea's width should have changed twice as much as it does now.
The cursor should have gone back to default when you finished resizing.
(Reporter)

Updated

2 years ago
Summary: Resizing a textarea inside a centered inline-block adds/subtracts from its width only half of the expected value → Resizing a textarea (or element with resize attribute) inside a centered inline-block adds/subtracts from its width only half of the expected value
(Reporter)

Updated

2 years ago
(Reporter)

Comment 1

2 years ago
The same problem happens when the element with "resize: both" is the inline-block element itself.
(Reporter)

Comment 2

2 years ago
Duplicated or related to bug https://bugzilla.mozilla.org/show_bug.cgi?id=1105906

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105906
You need to log in before you can comment on or make changes to this bug.