Cannot launch due to dynamic loading error.

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mzpppp, Assigned: mzpppp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

47 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/600.8.9 (KHTML, like Gecko) Version/8.0.8 Safari/600.8.9

Steps to reproduce:

1. Checkout master(2fafdf5).
2. Change bundle identifier and disable all capability because I don't own org.mozilla.ios.Fennec app id.
3. Build Client scheme.
4. Launch on physical device via Xcode.


Actual results:

dyld: Library not loaded: @rpath/SQLite.framework/SQLite
  Referenced from: /var/mobile/Containers/Bundle/Application/CA6C7B3B-4010-49F8-906D-D0F151C2C107/Client.app/Client
  Reason: image not found


Expected results:

Launch successfully.
(Assignee)

Updated

2 years ago
Summary: sqlite → Cannot launch due to dynamic loading error.
(Assignee)

Comment 1

2 years ago
Created attachment 8654567 [details] [review]
pull request
Attachment #8654567 - Flags: review?

Updated

2 years ago
Attachment #8654567 - Flags: review? → review?(rnewman)
Attachment #8654567 - Flags: review?(rnewman) → review?(sleroux)
Thanks for the fix! Looks good :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Attachment #8654567 - Flags: review?(sleroux) → review+
Assignee: nobody → mzpppp
Hmm, I'm still seeing these errors when running on my iPod touch (iOS 9).
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Something may have gone awry with a merge. Fixed again via 5af6800.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.