Installing unzipped signed extension package shows it couldn't be verified

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: TrendMicro_PCC, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8654689 [details]
Image 1.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.157 Safari/537.36

Steps to reproduce:

1. My Extension is in https://addons.mozilla.org/en-US/developers/addon/trend-micro-toolbar/versions/1744946

2. I downloaded it.My OS is Windows 7. Firefox version is 40.0.3.

3. Add a registry record in HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Firefox\extensions
Key : {22181a4d-af90-4ca3-a569-faed9118d6bc}
Value: C:\Users\{username}\Desktop\ffTB

4. Using WinRAR unzips the signed xpi package into the ffTB folder which was added in registry.(Just unzip directly and didn't do any change!)


5. Restart Firefox. 


Actual results:

In add-ons list, it shows our extension is not verified.(As the picture in attachment)

(Then I delete the extension. And install by xpi directly. It didn't shows that. Seems normal.)


Expected results:

It shouldn't show the verification warning when I use registry way to install my extension by unpacked xpi.

Updated

2 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
(In reply to TrendMicro_PCC from comment #0)
> Created attachment 8654689 [details]
> Image 1.png
> 
> User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML,
> like Gecko) Chrome/44.0.2403.157 Safari/537.36
> 
> Steps to reproduce:
> 
> 1. My Extension is in
> https://addons.mozilla.org/en-US/developers/addon/trend-micro-toolbar/
> versions/1744946

This link doesn't work for me, where can I find the extension?
Flags: needinfo?(consumer_pcc_mozilla_account)
(Reporter)

Comment 2

2 years ago
(In reply to Dave Townsend [:mossop] from comment #1)
> (In reply to TrendMicro_PCC from comment #0)
> > Created attachment 8654689 [details]
> > Image 1.png
> > 
> > User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML,
> > like Gecko) Chrome/44.0.2403.157 Safari/537.36
> > 
> > Steps to reproduce:
> > 
> > 1. My Extension is in
> > https://addons.mozilla.org/en-US/developers/addon/trend-micro-toolbar/
> > versions/1744946
> 
> This link doesn't work for me, where can I find the extension?

Can I have your email address? I can send the signed xpi package to you as an attachment.
Flags: needinfo?(consumer_pcc_mozilla_account)
My bugmail address works, dtownsend@mozilla.com
Flags: needinfo?(consumer_pcc_mozilla_account)
(Reporter)

Comment 4

2 years ago
(In reply to Dave Townsend [:mossop] from comment #3)
> My bugmail address works, dtownsend@mozilla.com

Hi Dave

I have found the reason lead to the problem.
It because windows generate the thumbs.db file which was hidden and regarded as system file. So it can't be seen.

I don't know when the file may generate. So it annoys me for a long time.
Flags: needinfo?(consumer_pcc_mozilla_account)
Ah that was going to be my first suggestion. You need to avoid viewing the add-on's contents in explorer or Finder on OSX both of which create hidden metadata files which will break the add-on's signature.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.