When replying to or forwarding an email, the email status returns to unread from read. Using IMAP.

RESOLVED DUPLICATE of bug 1284036
(NeedInfo from)

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1284036
2 years ago
a year ago

People

(Reporter: Les, Unassigned, NeedInfo)

Tracking

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Read an email. The status went from unread to read. So far so good. Replied to the email. Status went from read to unread. Not good. Same thing happens when forwarding a read email.


Actual results:

Email status goes back to unread after replying.


Expected results:

Email status should have stayed as read.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Summary: When replying to or forwarding an email, the email status returns to unread from read. → When replying to or forwarding an email, the email status returns to unread from read. Using IMAP.
Les, do you still see this issue?
If yes, is it all accounts, or just one?
Flags: needinfo?(lkalmus)
Whiteboard: [closeme 2016-10-01]
(Reporter)

Comment 2

a year ago
Yes. Happens all the time with all accounts. Drives me nuts.
How long as this been happening?
Whiteboard: [closeme 2016-10-01]
(Reporter)

Comment 4

a year ago
Probably a year more or less. Maybe even more than that. I really can't remember when it started but I have been using TB a very long time and this is relatively new.

Comment 5

a year ago
Les, I'm curious as to who you're email provider is. I've been experiencing the same issue, but it's only with my Godaddy IMAP accounts (secureserver.net). I use Thunderbird also with my Yahoo and Gmail accounts and have no issues when replying.
(Reporter)

Comment 6

a year ago
All of my accounts are IMAP and my provider for my most used emails is GoDaddy. I just did a test and replied to a message from a POP roadrunner email account and the problem did not happen. I also did the test using a different IMAP email whose provider is unknown with no problem so it looks like GoDaddy IMAP is the culprit. I guess I assumed that this was happening with all providers without checking carefully enough. I'm also not sure when I went to IMAP. It's entirely possible that this problem started when I did that because I believe I moved everything last summer in preparation for a long trip away from home.

Now that these tests show it's GoDaddy IMAP, I went to the GoDaddy webmail site. Neither message showed as unread even though the one I replied to from a GoDaddy IMAP account did in TB. I replied again to both messages from the web site and neither was set to unread there. After clicking on 'Get Messages' in TB to update the sent folder, neither of these new messages showed as unread.

It looks like GoDaddy is signaling something that causes TB to mark the replied to message as unread when writing to the sent folder or TB is incorrectly marking emails due to some other situation particular to GoDaddy accounts.

Comment 7

a year ago
Les, your findings duplicate mine. The issue is unique to the combination of Thunderbird and Godaddy IMAP accounts. 

NOTE: I have found that SeaMonkey behaves the same way, but I believe its email client utilizes alot of the same code as Thunderbird.
bug 1284036 covers the same issue and has somewhat more info, so duping this bug to there
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1284036
You need to log in before you can comment on or make changes to this bug.