Conn: ECN (Explicit Congestion Notification) "The operation timed out"

VERIFIED INVALID

Status

()

Core
Networking
--
minor
VERIFIED INVALID
17 years ago
15 years ago

People

(Reporter: Grant Kwok, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
This page will not load under Linux version. I'm using a fairly current build
(2002011108).  The page will load fine under Win32 version.  Not sure why this
is happening.

Comment 1

17 years ago
WFM  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020115

What do you mean by "will not load"?

The page does say it is not compatible with Netscape 6.
(Reporter)

Comment 2

17 years ago
Oops, sorry for the brief description.  What happens is that I get the
"Connecting to www.fido.ca" message on the status bar at the bottom and the
browser just hangs and eventually times out.  No page actually ever gets loaded,
I'm not sure what else it could be.  Just tried again using:  Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:0.9.7+) Gecko/20020111 but still no luck.

The Win32 daily's work fine and I see the message you are referring to. 
Bizzare, I wonder if they are doing a browser detect and are ignoring requests
from non Win32/Mac users - but since you saw the page, then that can't be case.

(Reporter)

Comment 3

17 years ago
This is what shows up when I run tcpdump and try to access that site.  Let me
know if this helps or if more details are needed.

00:58:11.166813 mybaby.33099 > proxy.fido.ca.http: SWE 1923585879:1923585879(0)
win 5840 <mss 1460,sackOK,timestamp 4928916 0,nop,wscale 0> (DF)
00:58:14.157297 mybaby.33099 > proxy.fido.ca.http: SWE 1923585879:1923585879(0)
win 5840 <mss 1460,sackOK,timestamp 4929216 0,nop,wscale 0> (DF)
00:58:20.157295 mybaby.33099 > proxy.fido.ca.http: SWE 1923585879:1923585879(0)
win 5840 <mss 1460,sackOK,timestamp 4929816 0,nop,wscale 0> (DF)
00:58:32.157302 mybaby.33099 > proxy.fido.ca.http: SWE 1923585879:1923585879(0)
win 5840 <mss 1460,sackOK,timestamp 4931016 0,nop,wscale 0> (DF)

Comment 4

17 years ago
I'm not a tcp-guru, but I think the "(0)" indicates no data sent, meaning that
the server/client are probably still trying to negotaite a connection, and you
never get an answer from the server.  This might not be a Mozilla bug.  Can you
ping the server?  If not, try traceroute.  Your packets might be getting
misrouted, or the server might be rejecting your IP address

Are you dual-booting or testing from different machines?  If you are
dual-booting and it works from Windows, then they must not be rejecting your IP
address...

also, "www.fido.ca" is an alias "proxy.fido.ca", so that part of the tcpdump is ok.
(Reporter)

Comment 5

17 years ago
Sorry, not dual booting so I can't check from Windows from the same machine...
however, I did find the cuplrit and so we I am marking this bug as resolved.

I had mistakenly turned on ECN (Explicit Congestion Notification) in my last
kernel recompilation.  This rejects many connections from many firewalls out
there (apparently), therefore I wans't able to connect to the site.  I noticed
the same thing was happening to a few other sites as well.

Anyway, I turned it off in the kernel, and it all works now!




Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Catching up.  Please reopen bug if there is still a problem.  Marking Verified!
Status: RESOLVED → VERIFIED
QA Contact: benc → jimmylee

Comment 7

16 years ago
changing summary b/c there is a dupe!
Summary: Does not load this page → Conn: ECN (Explicit Congestion Notification) problems

Comment 8

16 years ago
*** Bug 139340 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 221353 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
So, possibly no error w/ proxy config, and the normal error w/ direct connection.
Summary: Conn: ECN (Explicit Congestion Notification) problems → Conn: ECN (Explicit Congestion Notification) "The operation timed out"
You need to log in before you can comment on or make changes to this bug.