FTP links UI doesn't handle DNS lookup failures

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
3 years ago

People

(Reporter: lohphat, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
2002011403 on win2kpro-sp2

1. go to link
2. git "Go!" button to d/l file
3. you get fial open/save dialog, but when you select save to disk file is
created an nothing else happens.

In fact, the ftp server failed NDS lookup.  The proper dialog happens in NSCP 4.79

Comment 1

17 years ago
on linux, trying to load ftp://ftp.suc.spam.com (an invalid URL) spawns a dialog
window stating:

"You have chosen to download a file of type: "#1" [#2] from

What should Mozilla do with this file?

o Open using #1
o Save this file to disk
[]Always ask before opening this type of file


--

This seems to be almost a dup of bug 18007

Comment 2

17 years ago
hmm related to bug 120113?
(Reporter)

Updated

17 years ago
Summary: FTP liks don't process DNS lookup failure → FTP links UI doesn't handle DNS lookup failures

Comment 3

17 years ago
Reporter: Can you test this again with a fresh build?
I think it may be solved in Windows as well.

Comment 4

17 years ago
It's working in Windows 98, Build ID: 2002032003 (0.9.9+)
(Reporter)

Comment 5

17 years ago
Ergh...the test URL is now functioning -- need to find a server with a bad URL.
 This testcase was actually having DNS issues at the time of reporting.

Comment 6

17 years ago
Resolving WFM per last comment, as we have never back about a URL that does
still exhibit this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.