Finland Holidays include special days, not only official holidays

RESOLVED WORKSFORME

Status

Calendar
Website
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: kshji.github, Unassigned)

Tracking

Lightning 4.0.2

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8654972 [details]
FinlandHolidays.ics

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.157 Safari/537.36

Steps to reproduce:

Finland Holiday calendar include also other tasks, not only holidays.
Also calendar list says that Finland Calendar is -2015.
Here is my version about holidays in Finland. No extra tasks.
2010-2030
(Reporter)

Comment 1

3 years ago
I have shell script which do the cal file between years as you want using official holidays in Finland. Easy to fix. Easy to add other days if wanted (helluntai, pääsiäinen, laskiainen, ...) but those are not holidays. Currently those are not in  holiday cal file. Script do also csv file which include more days.

Comment 2

2 years ago
(In reply to kshji.github from comment #0) 
> Finland Holiday calendar include also other tasks, not only holidays.

I suppose you mean "special days", not tasks. Yes, the current calendar includes such special days too, but I would consider that a feature. E.g. you wouldn't find an official printed calendar with only the days you've included for sure, because there are days you're supposed to remember even if not an official holiday.

> Also calendar list says that Finland Calendar is -2015.

Well it's *complete* up to 2015, and now 2016 with bug 1234070. All the events that have regular occurrence in a way lightning lets you enter repetition goes on until forever. It's just the days with non-fixed days that have to be filled in later...

In contrast your generated file have all the fixed holidays set up as individual event, not repeating events which they really are.

What is the script, and more importantly what it your data source?
Summary: Finland Holidays include extra tasks, not only holidays → Finland Holidays include special days, not only official holidays

Comment 3

2 years ago
Bug 1185048 landed, it's now complete including 2016. 
As it is I'd close this bug as it's really less data and imho incomplete, as per comment 2.
Lets close it for now. You can still discuss if needed :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.