styles_base.xml:20: error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'.

RESOLVED DUPLICATE of bug 1195691

Status

()

Firefox for Android
Build Config & IDE Support
RESOLVED DUPLICATE of bug 1195691
2 years ago
2 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Searching this issue points me to:
https://code.google.com/p/android/issues/detail?id=183149

Which suggests either using sdk 23, which AFAIK we don't support yet, or some really hacky solution.

This is blocking my compile. I'm explicitly using sdk 22 so I'm not sure why it's checking 23 compat stuff:
> ac_add_options --with-android-ndk="/Users/bgirard/mozilla/android-ndk/android-ndk-r8e"
> ac_add_options --with-android-sdk="/usr/local/Cellar/android-sdk/23.0.2/platforms/android-22"

Mach error:
 0:43.70 /usr/local/Cellar/android-sdk/23.0.2/extras/android/support/v7/appcompat/res/values-v23/styles_base.xml:20: error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'.
 0:43.70 
 0:43.70 /usr/local/Cellar/android-sdk/23.0.2/extras/android/support/v7/appcompat/res/values-v23/styles_base_text.xml:19: error: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'.
(Reporter)

Updated

2 years ago
Blocks: 1200228
(Reporter)

Comment 2

2 years ago
Created attachment 8655051 [details]
newgroup workaround log

I've tried the work around posted in the newsgroup but it didn't work.
Flags: needinfo?(s.kaspari)
We have been able to fix the build on IRC.

I updated the guide to mention deleting the old version before extracting the downloaded zip.
https://mobile.etherpad.mozilla.org/109
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(s.kaspari)
Resolution: --- → DUPLICATE
Duplicate of bug: 1195691
You need to log in before you can comment on or make changes to this bug.