updating a favorite contact removes it from favorites

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Contacts
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: dietrich, Assigned: mancas)

Tracking

({foxfood, regression})

unspecified
FxOS-S8 (02Oct)
foxfood, regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [NG Gaia Contacts][patch][bzlite][only for NGA Contacts branch])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Aaarrrghh
(Reporter)

Comment 1

3 years ago
STR:

1. create a contact, make it a favorite
2. go back to list view
3. edit the new contact
4. change anything
5. got back to list view

Contact is no longer a favorite.
Keywords: regression, regressionwindow-wanted
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK v2.5
Build ID               20150819054940
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gaia Date              2015-08-19 12:01:44
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150819.063618
Firmware Date          Wed Aug 19 06:36:31 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK v2.5
Build ID               20150819061537
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gaia Date              2015-08-19 12:27:22
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150819.063618
Firmware Date          Wed Aug 19 06:36:31 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia-Rev        b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia-Rev        fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c
Possibly caused by Bug 1183727.
Keywords: regressionwindow-wanted
The bug can be reproduced on latest build of Flame KK v2.5 and Aries KK v2.5 by the STR in comment 1, but can't be repro on latest Flame KK v2.2.

Actual results: When user taps "Back" button at top left corner after editing the new contact, the contact is no longer a favorite.
See attachments: logcat_Aries_0444.txt, Aries KK v2.5.3gp.
Reproduce rate: 5/5


Device: Aries KK 2.5(Affected)
Build ID               20150831201650
Gaia Revision          c80e8ff25425b007181fd6e3de0500a0358fab37
Gaia Date              2015-08-31 16:35:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cafb1c90f794a73100a8f0afb9fe3301df0f2bde
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150831.193654
Firmware Date          Mon Aug 31 19:37:02 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Affected)
Build ID               20150831150202
Gaia Revision          c80e8ff25425b007181fd6e3de0500a0358fab37
Gaia Date              2015-08-31 16:35:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cafb1c90f794a73100a8f0afb9fe3301df0f2bde
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150831.183117
Firmware Date          Mon Aug 31 18:31:30 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2(Unaffected)
Build ID               20150831032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16d864d163de
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150831.065145
Firmware Date          Mon Aug 31 06:51:55 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Created attachment 8655335 [details]
logcat_Aries_0444.txt
Created attachment 8655336 [details]
Aries KK v2.5.3gp
[Blocking Requested - why for this release]:Regression. Blocking 2.5
blocking-b2g: --- → 2.5+
QA Whiteboard: [MGSEI-Triage+] → [foxfood-triage],[MGSEI-Triage+]
Component: Gaia::Feedback → Gaia::Contacts
Priority: -- → P1
Blocks: 1183727
Whiteboard: [bzlite] → [NG Gaia Contacts][bzlite]
Target Milestone: --- → FxOS-S7 (18Sep)
(Assignee)

Updated

3 years ago
Assignee: nobody → b.mcb
Created attachment 8659110 [details] [review]
[gaia] mancas:bug1200459 > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8659110 [details] [review]
[gaia] mancas:bug1200459 > mozilla-b2g:master

The issue here was simple. We were not saving the categories, so the the review will be quick and easy. Thanks Borja!
Attachment #8659110 - Flags: review?(borja.bugzilla)

Updated

3 years ago
Status: NEW → ASSIGNED
Whiteboard: [NG Gaia Contacts][bzlite] → [NG Gaia Contacts][patch][bzlite]
Attachment #8659110 - Flags: review?(borja.bugzilla) → review+
(Reporter)

Comment 9

3 years ago
Clearly this wasn't caught in any test, when it regressed (unclear which bugfix broke it).

Before landing, can you please add a test to ensure that future development doesn't break it yet again?
Manu, could you be so kind of adding the corresponding test as Dietrich suggest? Thanks a lot!
Flags: needinfo?(b.mcb)
After reverting the commits that gave us separated views in Contacts, the issue reported in this bug is not happening anymore in master (as it raised when bug 1183728 landed and it has already been backed out)

For that reason, removing the 2.5+ flag and adding [only for NGA Contacts branch] whiteboard to ensure that this bug need to be fixed in NGA branch (but not in current master branch).
blocking-b2g: 2.5+ → ---
Whiteboard: [NG Gaia Contacts][patch][bzlite] → [NG Gaia Contacts][patch][bzlite][only for NGA Contacts branch]
(In reply to Maria Angeles Oteo (:oteo) from comment #11)
> After reverting the commits that gave us separated views in Contacts, the
> issue reported in this bug is not happening anymore in master (as it raised
> when bug 1183728 landed and it has already been backed out)

Sorry, it raised when bug 1183727 landed and it has also been backed out
Created attachment 8663587 [details] [review]
[gaia] mancas:bug1200459 > mozilla-b2g:nga
(Assignee)

Comment 14

3 years ago
Comment on attachment 8663587 [details] [review]
[gaia] mancas:bug1200459 > mozilla-b2g:nga

Just making the PR against NGA branch
Flags: needinfo?(b.mcb)
Attachment #8663587 - Flags: review+
Target Milestone: FxOS-S7 (18Sep) → FxOS-S8 (02Oct)
Duplicate of this bug: 1207145
(Assignee)

Comment 16

3 years ago
Landed in nga: https://github.com/mozilla-b2g/gaia/commit/6f7b0147251f42d86ff7f5fa465636e5eec84597
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Checked in latest NGA branch (10/4) and working fine, thanks Manu for fixing this!
status-b2g-master: affected → unaffected
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 1.

Actual results: When user taps "Back" button at top left corner after editing the new contact, the contact is a favorite.
See attachment: verified_Aries KK_v2.5.3gp.
Reproduce rate: 0/10.

Device: Flame KK 2.5(Pass)
Build ID               20151007150205
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e1fa696e2b626ead6817b7c5bd871fec5d5ab5a
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.183338
Firmware Date          Wed Oct  7 18:33:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20151008002716
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c6ede6f30f3dc886543bb1c76fd7c8b5a151786b
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151007.234555
Firmware Date          Wed Oct  7 23:46:03 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Created attachment 8671198 [details]
verified_Aries KK_v2.5.3gp
status-b2g-master: unaffected → verified
You need to log in before you can comment on or make changes to this bug.