Closed Bug 1200472 Opened 4 years ago Closed 2 months ago

Broaden search criteria for password fill suggestions shown in the context menu affordance "Fill Password" to include subdomains.

Categories

(Toolkit :: Password Manager, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- disabled

People

(Reporter: ckarlof, Assigned: MattN)

References

Details

(Whiteboard: [passwords:cross-origin] [passwords:fill-ui])

Attachments

(5 files, 2 obsolete files)

I had less than ideal experience using the context menu to try to fill my BofA password this weekend.

I invoked the Fill Password affordance in the context menu on BofA to fill my password. It said "no suggestions". I was on www.bankofamerica.com, but the password was saved under secure.bankofamerica.com. 

I propose we should broaden search criteria shown in this suggestion list. Search second level domain (i.e., *.bankofamerica.com) or perhaps even ignore the scheme? We potentially have the opportunity to show the origin for each of the entries we suggest here, to minimize user error and confusion.
Severity: normal → enhancement
Summary: Broaden search criteria for password fill suggestions shown in the context menu affordance "Fill Password" → Broaden search criteria for password fill suggestions shown in the context menu affordance "Fill Password" to include subdomains.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589628
I'm going to undupe this since bug 589628 was going to cover both autocomplete and the context menu but the autocomplete code is being refactored in bug 1189618 and I don't want to block on that.
Assignee: nobody → saad
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
Priority: -- → P2
Whiteboard: [passwords:cross-origin]
Whiteboard: [passwords:cross-origin] → [passwords:cross-origin] [passwords:fill-ui]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Priority: P2 → P1
Flags: qe-verify+
Assignee: nobody → MattN+bmo
Mentor: MattN+bmo
Status: NEW → ASSIGNED
Attachment #8784074 - Attachment is obsolete: true
Attachment #8784163 - Attachment is obsolete: true

I found that macOS uses grey text outdented into the gutter with a separator above for this type of UI so that is what I'm following there.

To allow easier access from LoginManagerContextMenu.jsm since it didn't rely on this anyways.

Depends on D51353

Reduce the change of accidentally creating invalid test cases.

Depends on D52629

Attachment #9105708 - Attachment description: Bug 1200472 - Broaden search criteria for password fill suggestions shown in the context menu to include subdomains → Bug 1200472 - Include subdomain login fill suggestions in the context menu. r=sfoster
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/d38c2fbd306b
Move includeOtherSubdomainsInLookup pref lookup to LoginHelper. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/877779162b15
Make LoginManagerParent._searchAndDedupeLogins public and static. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/2e5826c18532
Don't allow creating invalid logins with LTU.TestData helpers. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/c72321ba48b8
Include subdomain login fill suggestions in the context menu. r=sfoster

The UI addition will be reverted in bug 1599752 since bug 1595915 will remove the login submenu altogether. The majority of https://hg.mozilla.org/integration/autoland/rev/c72321ba48b8 is reverted while the other commits remain.

You need to log in before you can comment on or make changes to this bug.