bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Top Sites site removal yields temporary black thumbnail

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-v1.0 affected, fxios-v1.1 affected, fxios-v1.0.5 unaffected, fxios1.1+)

Details

Attachments

(1 attachment)

(Assignee)

Updated

3 years ago
status-fxios-v1.0: --- → unaffected
status-fxios-v1.0.5: --- → unaffected
status-fxios-v1.1: --- → affected
tracking-fxios: ? → 1.1+
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
(Reporter)

Comment 1

3 years ago
1.0 is affected on the store
status-fxios-v1.0: unaffected → affected
(Reporter)

Comment 2

3 years ago
Probably an iOS 9 regression
(Assignee)

Comment 3

3 years ago
Just tried this out in the iPhone 6 (9.0) simulator off of master and can't reproduce it. Is this still an issue?
Flags: needinfo?(aaron.train)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

3 years ago
This is reproducible still. This seems to happen after a Sync with excessive top-sites.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [Swift 2.0] - Top Sites site removal yields temporary black thumbnail → Top Sites site removal yields temporary black thumbnail
(Reporter)

Comment 5

3 years ago
Just start deleting a bunch after a Sync and you'll see what I see in the video.
(Assignee)

Comment 6

3 years ago
Created attachment 8670830 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1135

Simple fix. Synced top sites asynchronously fetch their thumbnails and the background image background is default to black which caused the jarring effect. Just changed it to white.
Attachment #8670830 - Flags: review?(bnicholson)
Attachment #8670830 - Flags: review?(bnicholson) → review+
(Assignee)

Comment 7

3 years ago
Merged
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.