Unable to copy paste image inline into hotmail / outlook.com emails

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

Firefox 40
x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Microsoft][platform-rel-Outlook])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Copying an image (any jpg) from a website and attempt to paste it inline into a hotmail / outlook.com email. Image does not appear. Tried clean profile too.

Works fine in Internet Explorer.

Possibly related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=507110
https://bugzilla.mozilla.org/show_bug.cgi?id=825210

Comment 1

3 years ago
I can reproduce this. Annoyingly, it works fine on gmail, and in simple testcases like http://jsbin.com/xayahetexe/edit?html,output or http://jsbin.com/gadiqahetu/edit?html,output . The problem is with their JS, which (in obfuscated version) does this:

      t && (t.files.length > 0 ? this._fileSelection(n)  : t.getData('Text') || (n.stopPropagation(), n.preventDefault()))

which is in an onbeforepaste handler, with 't' the data transfer object from the paste event. Because we don't expose files for copied images, and because there is no text, the paste is being prevented by this code. I don't know what other browsers do here - outlook live doesn't seem to be giving IE the same JS. Karl, can you look at this in more detail and/or contact MS?
Component: General → Desktop
Flags: needinfo?(kdubost)
Product: Firefox → Tech Evangelism
Version: 40 Branch → Firefox 40
Redirecting to Hallvord for diagnosis.
Flags: needinfo?(kdubost) → needinfo?(hsteen)
Whiteboard: [needsdiagnosis]
Like bug 803014 this one boils down to two issues: whether we implement the expected APIs and whether the site uses them. There's an uglier hack the site can fall back to if the APIs are not supported but I'm reluctant to recommend taking advantage of that.. (The hack which GMail also uses is to make sure the paste goes into a rich text editing area (might be a hidden one to keep the markup in your main editor sane), grab the data: URL from the generated IMG tag and process the image data.)

I'd like to revisit this after bug 906420 and bug 891247 are fixed. If it doesn't start working we'll have to do some more analysis and outreach.
Depends on: 906420, 891247
Flags: needinfo?(hsteen)
Whiteboard: [needsdiagnosis] → [needsdiagnosis][platform-rel-Microsoft][platform-rel-Outlook]

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
platform-rel: ? → -
Created attachment 8779500 [details]
Screen Shot 2016-08-09 at 4.28.11 PM.png

Just tested, and this is working now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [needsdiagnosis][platform-rel-Microsoft][platform-rel-Outlook] → [platform-rel-Microsoft][platform-rel-Outlook]
(likely because bug 906420 and bug 891247 and fixed)
You need to log in before you can comment on or make changes to this bug.