Drop-shadow on large SVG path stroke truncate corners

RESOLVED DUPLICATE of bug 1153845

Status

()

RESOLVED DUPLICATE of bug 1153845
3 years ago
3 years ago

People

(Reporter: thomas, Unassigned)

Tracking

({testcase})

40 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826185918

Steps to reproduce:

1. Declare an SVG with a path
2. Use a large stroke for this path, ex: `stroke-width: 30px;`
3. Add a drop-shadow on the SVG or the path, ex: `filter: drop-shadow( 0 2px 1px black );` 

Testcase online http://jsfiddle.net/tzi/kojh2xLk/ or attached.


Actual results:

The path corner are truncated


Expected results:

The path corner should be sharp.
(Reporter)

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
Created attachment 8655677 [details]
bug 1200844  testcase - drop-shadow + large stroke.html
(Reporter)

Updated

3 years ago
Keywords: testcase
Oh no :(
This is fixed in Nightly, and I'm pretty sure it was bug 1153845 that fixed it. Looks like I should have requested uplift to Firefox 40 on the patch there... sorry about that.
It'll be fixed in Firefox 41 then.

Just to make sure I'm on the right track, can you test whether this is fixed in Firefox 41 Beta?
(Reporter)

Comment 3

3 years ago
Yes. It seems fixed on Firefox 41 Aurora.

Thanks ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153845
You need to log in before you can comment on or make changes to this bug.