itunes:new-feed-url tag is inappropriately changing url

RESOLVED INVALID

Status

Thunderbird
Preferences
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: drm, Unassigned)

Tracking

41 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

I have subscribed to a podcast that uses itunes:new-feed-url to redirect itunes users to use m4a format files rather than mp3. Not being an ipod user, this is a problem for me. https://support.mozilla.org/en-US/questions/1080801 The publisher claims that Thunderbird's use of this tag is non-standard, and I agree. Could there at least be an option to turn off this behavior?

This bug references the implementation, https://bugzilla.mozilla.org/show_bug.cgi?id=304917.

Comment 1

3 years ago
The publisher is quite incorrect, and should read the very simple and clear specification[1]. No additional code or complexity, which affects everyone, will be added as a result of this publisher's misuse of the tag, which error doesn't manifest in less featurefull feed readers that haven't implemented the spec.

[1] http://www.apple.com/itunes/podcasts/specs.html#newfeed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 2

3 years ago
I would respectfully disagree with alta88's comment that new-feed-url is a publisher's misappropriation of Apple's spec.  Apple's specification relates to changing feeds for iTunes Store and has unfortunately been used outside that scope.

This functionality in Thunderbird has become an issue to our consumers.  At this point, we have to tell them to downgrade or find a different feed reader.  new-feed-url should only be used in two situations: 

(a) with a 301 redirect help new and existing consumers of iTunes Store feeds move to a new feed 
(b) to point the iTunes Store to our m4a's with chapters, while non-iTunes Store feeds can pull the mp3

I would request that this bug be re-opened and a solution be discussed/implemented.  Maybe turn it off by default?

Comment 3

3 years ago
If it's used outside the scope of the spec, it's by definition a misappropriation. 

Why is the tag in the feed file at all?  Why is it using the itunes namespace if it isn't for the specific and clear purpose itunes has specified?  You need to remove the tag if you don't want it do what it's intended to do, pretty simple.

You've added some conditions to the tag, which are neither in Apple's spec nor any spec; that isn't how specs work.

Comment 4

3 years ago
I believe we are using the <itunes:new-feed-url> tag correctly.  Even though the itunes namespace is included in the RSS feed, a non-iTunes Store feed reader should not utilize tags in that namespace.

Much like DICOM, the Apple specification allows for some interpretation.  It can be interpreted that the <itunes:new-feed-url> tag allows us to provide a standard mp3 RSS feed to standard readers but when the iTunes store reads our feed, it can utilize the itunes namespace to pull m4a's instead of the mp3's.

In summary, I believe that tags in the itunes namespace should only be used by the iTunes Store feed reader and that any other reader should ignore those tags or give the user a way to disable processing of those tags.
(Reporter)

Comment 5

3 years ago
I fixed it myself with a little hacking. If anyone else has this problem I can tell you what you need to do.
You need to log in before you can comment on or make changes to this bug.