testcase matrice for javascript object image gives failures

RESOLVED DUPLICATE of bug 69196

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 69196
17 years ago
17 years ago

People

(Reporter: stefanh, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

When running testcase matrices at page
http://mozilla.org/quality/browser/standards/javascript/tcmatrix/index.html
in section "images" failures on pages img001.html (Read image.border 0 failure),
img005.html ( Read image.hspace 10 failure), img006.html (Read image.vspace 10
failure) and img008.html (Read image.lowsrc../res/lowstar.gif failure)

Reproducible: Always
Steps to Reproduce:
1.Go to http://mozilla.org/quality/browser/standards/javascript/tcmatrix/index.html
2. Go to test cases: border, hspace, vspace & lowsrc
3.

Actual Results:  border: -1
hspace: -1
vspace: -1
lowsrc: undefined

Expected Results:  border: 0
hspace: 10
vspace: 10
lowsrc: ../res/lowstar.gif
(Reporter)

Comment 1

17 years ago
Sorry, running OS 9.1, not 8.6 

Stefan
OS: Mac System 8.5 → Mac System 9.x
(Assignee)

Comment 2

17 years ago
Is this testcase still valid?
The lowsrc testcase is no longer valid, since that was removed.  The others are
valid.

The problem is that border, hspace, vspace are all declared using
NS_IMPL_INT_ATTR.  Their units are not eHTMLUnit_Integer, but eHTMLUnit_Pixel,
however.  Hence the getter returns -1 instead of the real value.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac System 9.x → All
Hardware: Macintosh → All
This got fixed by the patch in bug 69196.

*** This bug has been marked as a duplicate of 69196 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Testcase still gives failures, using build 2002020405 (Mac OS 9.1) Is the
testcase correct?
Please test with a 2002-02-05 build. The fix for bug 69196 landed last night.

The lowsrc testcase is still wrong (we no longer support that).  The other
testcases pass.
You need to log in before you can comment on or make changes to this bug.