keyboardinterrupt hang sometimes

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: parkouss, Assigned: parkouss)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Sometimes hitting ctrl-c, mozregression can take a few seconds to stop.

The root cause is because we are waiting for threads to join, using concurrent.futures. While this module is great, it does not allow the daemon thing that standard python does. So we can't abruptly kill threads on exit, and sometimes mozregression hangs (thus depending on the network as we are mainly doing network related work in threads).
(Assignee)

Updated

2 years ago
Summary: keyboarinterrupt hang sometimes → keyboardinterrupt hang sometimes
(Assignee)

Comment 1

2 years ago
Created attachment 8655755 [details] [review]
keyboard interrupt hangs sometimes

So this patch remove the concurrent.future dependency, and allows ctrl-c to finish almost instantly (within 0.1 second, this is not noticeable).
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8655755 - Flags: review?(wlachance)
Comment on attachment 8655755 [details] [review]
keyboard interrupt hangs sometimes

This looks sensible, it's too bad we can't get concurrent.futures to do what we need here. :(
Attachment #8655755 - Flags: review?(wlachance) → review+
(Assignee)

Comment 3

2 years ago
Yes, this seems to be a bug of the backport for python 2.7 of futures, see https://github.com/ross/requests-futures/issues/14.
(Assignee)

Comment 4

2 years ago
Landed in https://github.com/mozilla/mozregression/commit/27038a5791a529242eaf38b2ea5758192cf63910.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.