Hotkeys on the Preferences page require Alt-Shift rather than Alt (which is used in the rest of the app)

REOPENED
Unassigned

Status

()

Firefox
Preferences
REOPENED
3 years ago
2 months ago

People

(Reporter: Martin Stružský, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150827142634

Steps to reproduce:

1. Go to Options page.
2. Pres Alt + any of the underlined letters.


Actual results:

Nothing happens or a menu drops down (depends on the letter selected).


Expected results:

Checkboxes should trigger, buttons should be pressed etc.
The right shortcut is Shift+Alt+key [1], which works fine. Eventually you can adjust it by about:config preference [2], but Alt+key won't work well, as Alt has its own functionality already.

[1] https://support.mozilla.org/en-US/kb/accessibility-features-firefox-make-firefox-and-we#w_html-access-keys
[2] http://kb.mozillazine.org/Ui.key.contentAccess
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Hang on a moment... for things still implemented in XUL and non in-content, like the History window, the key is Alt. So it seems like we are telling our users to use a different key here depending on our underlying implementation choices. That doesn't seem right to me.

I'd also note that the key allocation is a mess at the moment. On the General preferences, for example, there are several instances of clashing keys (W, C) and several items which don't have a key at all...

Gerv
Status: RESOLVED → REOPENED
Component: Untriaged → Preferences
Ever confirmed: true
Resolution: WORKSFORME → ---
Summary: Hotkeys not working on the revamped Options page → Hotkeys on the Preferences page require Alt-Shift rather than Alt (which is used in the rest of the app)

Comment 3

2 months ago
If we're going to require one part of the UI to violate the expectations that have been built up using another part we need to at the least make it trivial to resolve the violation.

I just started typing up a new bug on this before I was drawn here because it wasn't obvious that SHIFT + had to be added to the hotkey macro. I've personally never encountered any other UI that's required that for hotkey activation and assumed it was broken.

Most end users won't come to bugzilla to figure it out.
You need to log in before you can comment on or make changes to this bug.