If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some image maps generated by Homesite 4.5.2 not working.

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Marcin Orlowski, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(Whiteboard: [TOOL][HOMESITE])

(Reporter)

Description

16 years ago
Seems Mozilla (0.9.7 official build, Windows, but I expect All to apply, please
check and confirm) is very sensitive to Image Map Y coordinate and it ignores 
image map element (area in this case) if Y value of starting point is bigger
than Y of ending point. For example, this element will not work in your map:

<area coords="267,43,400,9" href="somewhere">

However this, makes no problems:

<area coords="267,9,400,43" href="somewhere">

Setting severity to major, due to end user problems this bug leads to.

Comment 1

16 years ago
http://www.w3.org/TR/html401/struct/objects.html#adef-coords

rect: left-x, top-y, right-x, bottom-y. 

testcase stuck in the url field.  Note that nc4 and moz behave the same. if you 
switch to using correct coordinates, they'll both work.

irc.mozilla.org#evangelism is committed to evangelizing real sites that mess up 
in this fassion.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
''correct'' meaning Euro-centric, in this case.

Four descriptions of the same rectangular area:
coords="267,9,400,43"  u_l | l_r
coords="267,43,400,9"  l_l | u_r
coords="400,9,267,43"  u_r | l_l
coords="400,43,267,9"  l_r | u_l

Only upper_left | lower_right works ... just the way "we" write.
(Reporter)

Comment 3

16 years ago
Be serious. If you prefer wasting your time on irc to debate
about that instead of fixing/enchancing (name as you want)
this feature, don't be surprised hearing "Mozilla sucks,
because site AAA.com does not work".

Let's get the point. If you can describe rectangular area 
by giving coords of 2 corner points, considering only one
case of four as valid is illogical. Even w3c.org designed
it that way, it still makes no much sense in enforcing
that scheme as the only one. Life has proven that too many 
people don't know this exact w3c.org rule. Even
Homesite, the leading Windows editor generates maps the
way Mozilla can't stand. There are too many of sites around
with maps like that. Let's face it: too many to defeat. So
please point me to any reasonable excuse what we shall keep
this "Resolved invalid" instead of fixing that problem? 
Don't forget to tell all Mozilla ordinary users what
w3c.org is and why they should accept the fact they shall
access some sites with MSIE instead of Mozilla.

Comment 4

16 years ago
Ok, following Timeless' advice, let me rephrase this bug:

Some of image maps using "Rect" are not working with Mozilla, because they have
coordinates of rectangle's extreme corners listed in wrong order. Macromedia's
Homesite generates these from time to time, probably depending on the order in
which user drawn the rectangle.

The URL of this product: http://macromedia.com/software/homesite/

This could potentially influence a lot of sites, as homesite is one of most
popular web editors.

Reopening and reassigning to Evangelism.
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → US General
Product: Browser → Tech Evangelism
Resolution: INVALID → ---
Summary: Image map Y coordinate sensivity → Some image maps generated by Homesite 4.5.2 not working.
Version: other → unspecified

Comment 5

16 years ago
reassign
Assignee: asa → doronr
QA Contact: doronr → zach

Comment 6

16 years ago
I am downloading a trial to investigate this.  Current version is Homesite 5,
though.
Whiteboard: [TOOL][HOMESITE]

Comment 7

16 years ago
I could not recreate in trial of Homesite 5.  I tried multiple ways of drawing
rectangular image map links.
2002030908/WinXP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 8

15 years ago
After all this preaching, the problem in Mozilla was also fixed. See bug #162546.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.