Status

--
minor
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: comqas, Assigned: mscott)

Tracking

Trunk
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I use my portable at home and at work and my machine changes its IP address
between the two but the POP3 address remains the same. When I suspend the
machine before going to work, Mozilla is usually running. When I wake the
machine up at work and it executes interface up on eth0, Mozilla Mail does not
connect with the POP3 server. No diagnostic is produced, simply the GetMsg
button, when pressed, has no effect. If I quit Mozilla and re-start it, it
behaves as normal, allowing me to get new messages.

Sorry I don't remember whether the browser itself allows me to get Web pages
as I always quit Mozilla at this point (mail is the first thing I do after
getting to work).

*** This bug has been marked as a duplicate of 26718 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: access to POP3 → access to POP3
verified dup.
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
Reporter, please do the following:

Create a test profile, and use the IP address of your POP mail server.

See if you have the same problems connecting.

Comment 4

17 years ago
Actually, we need clearer steps for this problem.

reporter: can you create a test profile where you use the IP address for your 
pop mail server (not the hostname).

This should work, and what you would find is that your old DNS server is not 
visible to you from the new network connection.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
Reporter: Please answer comment 4
(http://bugzilla.mozilla.org/show_bug.cgi?id=120105#c4)

Thanks!
(Reporter)

Comment 6

17 years ago
Comment #4 does not make sense. If the DNS was to blame, how come terminating
mozilla and starting it again ALWAYS cures the problem? Surely the DNS resolver
is unaffected by a Mozilla restart? 

Comment 7

17 years ago
DNS is accessed through a library that allows the reading of the DNS server
list. Mozilla currently has no robust way of updating that list of
/etc/resolv.conf changes.

Please provide the requested info. If you match previously reported bugs, then
you will find all the information you need when a contributor marks this a
duplicate.

Comment 8

16 years ago
no response from reporter for a couple of months, so resolving WFM.

reporter (Alex): if you're still around and can reproduce this problem with a
recent build of mozilla (e.g. 1.1beta), please reopen this bug and provide the
requested diagnostics...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
REOPEN:
This problem is actually still around because the fix in bug 117628 has problems
(described in bug 166479).

I'd like to have mailnews QA see if this problem can still be duplicated:

1- Start linux system w/ modem.
2- Start mozilla.
3- Dial network.
4- Use mozilla to read mail.

(If someone is familiar w/ DCHP, then using "pump" and hacking on
/etc/resolv.conf might get the same results.)
Status: RESOLVED → UNCONFIRMED
Depends on: 117628
Resolution: WORKSFORME → ---

Updated

16 years ago
Depends on: 166479

Comment 10

16 years ago
Is this a dupe of bug 64857 as set before? If not, is it still happening?

pi

Comment 11

16 years ago
No response, marking WFM.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.