After updating a contact the statusbar turns from blue to grey

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Contacts
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: gsvelto, Assigned: borjasalguero)

Tracking

({regression})

unspecified
FxOS-S7 (18Sep)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [NG Gaia Contacts][patch])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
STR:

1. Go in the contacts up, ensure that you have at least one contact already
2. Select a contact
3. Start editing the contact
4. Change one field then tap update

Expected result:

When going back to the contact list the status-bar does not change color (i.e. it remains the default blue/green hue)

Actual result:

The status-bar becomes light-grey

I'm not sure if this is a contacts or system app bug, I'm filing it in contacts for now because it requires interaction with the contacts app to be triggered
This issue is not present in a master from 15 days ago[1]. 

[Blocking Requested - why for this release]: Visual regression

[1] Build ID               20150817141354
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a6eeb28458fd2652e12e57334f046b7776d75bb4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150619.224059
Firmware Date          Fri Jun 19 22:41:08 UTC 2015
Bootloader             s1
blocking-b2g: --- → 2.5?
Keywords: regression
Duplicate of this bug: 1202220
From bug 1202220:
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819054940
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gaia Date              2015-08-19 12:01:44
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819061537
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gaia Date              2015-08-19 12:27:22
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro 
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

First Broken Gecko & Last Working Gaia - issue DOES NOT repro 
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c

Possibly caused by Bug 1183727. Could you take a look Borja?
Flags: needinfo?(borja.bugzilla)
Comms triage: Not a functional regression. High priority to fix, though
blocking-b2g: 2.5? → ---
tracking-b2g: --- → backlog
Priority: -- → P1
Blocks: 1183727
Whiteboard: [NG Gaia Contacts]
Target Milestone: --- → FxOS-S7 (18Sep)
(Assignee)

Updated

2 years ago
Assignee: nobody → borja.bugzilla
Flags: needinfo?(borja.bugzilla)

Comment 5

2 years ago
Created attachment 8657798 [details] [review]
[gaia] borjasalguero:fix_detail_color > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8657798 - Flags: review?(francisco)
Whiteboard: [NG Gaia Contacts] → [NG Gaia Contacts][patch]
Attachment #8657798 - Flags: review?(francisco) → review+
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Tested in latest master build (9/9) and working as expected. Thanks borja for fixing this issue!

Environmental Variables (9/9):
flame master (2.5 version)
Build ID: 20150909070122
Gecko: eea972e
Gaia: 404a35a
Platform version: 43.0a1

Comment 7

2 years ago
Created attachment 8659004 [details]
Verified video: Aries_v2.5.3GP

This bug has been verified as pass of latest Aries KK v2.5.
STR: 
Same STR with comment 0,
See video:"Aries_v2.5.3GP"
Repro rate: 0/10

Actual result:
The color of status bar will never change.

Aries KK v2.5(pass):
Build ID               20150909215153
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.211310
Firmware Date          Wed Sep  9 21:13:17 UTC 2015
Bootloader             s1

Updated

2 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.