PushService/PushDB does not properly cleanup channel IDs

RESOLVED DUPLICATE of bug 1201128

Status

()

Core
DOM: Push Notifications
RESOLVED DUPLICATE of bug 1201128
2 years ago
2 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Sending too much channel IDs was identified as the root cause of multiple Push service TCP reset, as documented in bug 1189729 comment 66 and subsequents.

People confirmed a fresh PushDB do not exposes the issue. We got report, in bug 1189729 comment 75, that it started to happen after a while. So obviously something is going on in the Gecko PushService/PushDB.
The problem is that old ChannelIDs are not being purged by client apps, so there's a large number. This would force the server to accept larger and larger packets which is very problematic. 

The fix is for the Push Hello to NOT send ChannelIDs, since they're ignored by the server anyway.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201128
You need to log in before you can comment on or make changes to this bug.