unable to initialise debugger (BadMojo 4)

RESOLVED WONTFIX

Status

Other Applications
Venkman JS Debugger
RESOLVED WONTFIX
16 years ago
13 years ago

People

(Reporter: Russell Edkins, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Can't give URL as it's behind a fully secured firewall. Sorry. But here's the 
background. I had NS6.1 (loaded from a CD some time ago), I upgraded to 6.2.1 
from ftp.netscape.com, went to http://www.mozilla.org/projects/venkman/venkman-
install.html , and clicked on install win32-0.6.2 . When I tried to launch the 
debugger from tasks/tools/Javascript Debugger, I got the following error: 

An exception occurred while initializing, please file a bug.
BadMojo4: JS Debugger Service is not installed. @
chrome://venkman/content/venkman-debugger.js:112 (initDebugger)

When I click the ok button in the error box, the debugger starts, but I can't 
get it to load any scripts.

Good luck.

Russ.
(Assignee)

Comment 1

16 years ago
Please reboot your computer and try again.  Some windows installs require a
reboot to complete the install.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Severity: major → blocker
Keywords: crash
(Assignee)

Comment 2

16 years ago
This is neither a blocker, nor does it crash (according to your initial report,
at least.)

It's most likely an install problem.

Have you tried rebooting yet?
Severity: blocker → normal
Keywords: crash
(Assignee)

Comment 3

16 years ago
Oh, my bad, it wasn't Russ who changed those fields.
(Assignee)

Updated

16 years ago
Summary: Crash on startup - unable to initialise debugger (BadMojo 4) → unable to initialise debugger (BadMojo 4)
(Assignee)

Comment 4

16 years ago
Russ, do you have jsd3250.dll in your components directory?

This works for most everyone else after a reboot, I'm stumped.
Status: NEW → ASSIGNED

Comment 5

16 years ago
I'm having exactly the same problem, which persists after a reboot.  I'm also 
using Windows 2000 server, so this may be related.

Comment 6

16 years ago
Forgot to mention that I DO have jsd3250.dll in the components directory 
(C:\Program Files\Netscape\Netscape 6\components).  I also have Netscape 4 
installed on the same machine.

Comment 7

16 years ago
I've now successfully installed the debugger on my Win2K server by following 
these steps:
- uninstalled Netscape 4
- uninstalled Netscape 6
- deleted C:\Program Files\Netscape (the unistall for Netscape 6 didn't remove 
this)
- rebooted
- reinstalled Netscape 6, taking all defaults.  My initial installation was a 
custom, installing only the Navigator component, and additional components Sun 
Java 2, Quality Feedback Agent, and Classic Skin
- reinstalled the debugger
- rebooted (without even attempting to bring up the debugger)
After I did all this, the debugger worked.  So the problem is connected either 
with Netscape 4 on the same machine, a custom install, or attempting to use the 
debugger before rebooting.  Hope this helps.
(Assignee)

Comment 8

16 years ago
Of these, the idea that using the debugger without a reboot (on some windows
systems) is the most likely.

If you're not tied to NS6 for a specific reason, the latest mozilla build will
have a more recent debugger, and can be installed by default.

Comment 9

16 years ago
Note that I did try rebooting before I tried the procedure above.  The only 
difference here (aside from the deinstalls and reinstalls) is that I didn't 
even attempt to use the debugger until after the reboot.  Are you saying that 
bringing up the debugger without first rebooting causes some kind of permanent 
damage so that even a subsequent reboot doesn't help?  This should certainly be 
noted in the installation procedure.

Comment 10

16 years ago
Unfortunately, I'm going to have to reopen this issue.  I tried to install the
debugger on a second box running NT4.  I followed these steps:
- deinstalled all versions of Netscape
- deleted all references to Netscape or Mozilla from the registry
- rebooted
- installed Netscape 6.2.1 from the Netscape web site
- rebooted
- installed the debugger
- rebooted
- attempted to use the debugger.  No dice - I get the "bad mojo" message.  This
issue is easy to reproduce and a complete showstopper.  Can I raise the
priority?  If necessary, I can make the box available to you - please email me
(tooda01@ca.com) if you'd like to do this.
(Assignee)

Comment 11

16 years ago
I'm sorry, I'm not going to he able to help out with debugger on 6x at this
point.  Please use a mozilla nightly for javascript debugging.

Also, the next netscape branded browser will work with the latest venkman version.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.