Add to Address Book, enter First Name and Display Name overwritten

VERIFIED DUPLICATE of bug 121709

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 121709
17 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Trunk build 2002-01-15-03:WinMe

Overview: If a message includes an email address that has a pretty name, then
Add to Address Book, enter a First Name and the Display Name is overwritten.

Steps to reproduce:
1. Select a message which includes an address in the form of 
"Pretty Name <user@domain.com>" (i.e. Smitty <jsmith@test.com>
2. Right click on the address and choose the "Add to Address Book" option
3. When the New Card dialog appears notice that the Display Name (John Smith)
and Email Address (jsmith@test.com) is automatically filled in.
4. Enter a First Name

Actual Results: The Display Name disappears and is replaced with the text
entered for the First Name. (i.e. Smitty becomes John)

Expected Results: If a Display Name exists then entering a First and Last Name
in the New Card dialog should not change the Display Name.

Additional Information:
1. The problem does not occur for cards already existing in the Address Book.
For instance, in the Address Book create a card with only a Display Name and an
Email Address, OK. Then reopen the card, enter a First Name and the Display Name
does not change.
(Reporter)

Comment 1

17 years ago
Marking nsbeta1 since the results in data loss. The workaround is easy but it
creates more work than necessary. 

Thanks to Seth for finding this problem.
Keywords: nsbeta1
QA Contact: esther → nbaca

Comment 2

17 years ago
dupe of bug 55054 ?
(Reporter)

Comment 3

17 years ago
Marking a dupe of bug# 121709 since this later bug includes a fix.

*** This bug has been marked as a duplicate of 121709 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.