Closed Bug 1201795 Opened 7 years ago Closed 2 years ago

Firefox reports an extra row with hidden caption and prevents NVDA from reading rest of table with row nav

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 995888

People

(Reporter: sina, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In the attached html file, you can simply remove the sr-only class off of the caption to make this bug disappear. With that class there, NVDA says "edge of table" after the first row. Furthermore, 5 instead of 4 rows is reported. To reproduce, simply run NVDA, arrow into the table, and then try to use row nav e.g. ctrl+alt+downArrow to get past the header.

The extra row being reported, I believe, is captured in bug #995888: https://bugzilla.mozilla.org/show_bug.cgi?id=995888

However, that still does not address the screen reader implication of being trapped in the header.
The key difference from bug 995888 is that here, there is a thead and a tbody. The broken "caption" row seems to be counted between the last row of the thead and the first row of the tbody, which breaks NVDA's ability to navigate by row out of the thead. This is pretty nasty, as the user gets "trapped".

I'll leave the decision as to whether to mark this as a duplicate up to the Mozilla a11y team. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Surkov, your thoughts?
Blocks: tablea11y
Flags: needinfo?(surkov.alexander)
yep, it's likely a dupe of bug 995888
Flags: needinfo?(surkov.alexander)

NVDA is now more tolerant of tables with missing rows, so the user no longer gets trapped during table navigation in this case. Therefore, I'm closing this as a duplicate of bug 995888, since the user impact is now essentially the same.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 995888
You need to log in before you can comment on or make changes to this bug.