Implement option to remove new "All Address books" parent node (return to old AB tree style)

RESOLVED DUPLICATE of bug 1308776

Status

RESOLVED DUPLICATE of bug 1308776
3 years ago
9 months ago

People

(Reporter: h-inagaki, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(1 attachment)

31.54 KB, application/x-zip-compressed
Details
(Reporter)

Description

3 years ago
Created attachment 8657003 [details]
information.zip

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

Steps to reproduce:

Use Version : Thunderbird v38

The Address Book upon version 38 has been changed to the attached
screen shot (ver38.jpg), the "Personal Address Book" and the
"Collected Address Book" under the "All Adress Books".

However, we want to use the previous style Address Book without
the "All Adress Books" in any time, like before_ver38.jpg.

There is no preference to do it, so we want you to add the preference
to change the address book to the previous style.
Please explain why this is a problem for you (steps to reproduce / actual result / expected result).

We have some wip bugs to remember the last user-selected AB upon reopening, although I'm not sure that solves the problem. We probably need to give the user a choice which AB he wants to see upon opening main AB window, and possibly include "remember" as one option.
Whiteboard: [dupeme]
Summary: Change address book style → Implement option to remove new "All Address books" parent node (return to old AB tree style)
(Reporter)

Comment 2

3 years ago
Before version 38, when we opened the address book windows, we were able to select the "Personal Address Book" first.

However, we can't read the "Personal Address Book" immediately because there are the "All Adress Books".

I think that it is inconvenient. So, we want the way to change the address book to the previous style.
(In reply to h-inagaki from comment #2)
> Before version 38, when we opened the address book windows, we were able to
> select the "Personal Address Book" first.
> 
> However, we can't read the "Personal Address Book" immediately because there
> are the "All Adress Books".

So you want to open the main address book with "Personal Address Book" as a default startup view. That makes this a duplicate of bug 1308776, which is going to ship in the next release version soon.

> I think that it is inconvenient. So, we want the way to change the address
> book to the previous style.

That's a possible, but not necessary solution for what you really seem to want, having "Personal Address Book" show up first as a default, which is bug 1308776. So unless someone shows how the mere existence of "All Address Books" node breaks their workflows (which imo is unlikely), I think we would neither remove "All Address Books" node nor make its presence optional (wontfix).

Thank you for filing this bug report, pls wait for the next release version where you can set "Personal Address Book" as your default startup AB.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308776
You need to log in before you can comment on or make changes to this bug.