Log the image id used in a task

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
6 months ago

People

(Reporter: dustin, Assigned: wcosta)

Tracking

Details

(Whiteboard: [docker-worker])

In general we should try not to re-use tags, but currently that's a little hard in try.  Sometimes I see a job that says something like

  quay.io/djmitche/desktop-build:0.1.1 exists in the cache.

and I'm left wondering, *which* desktop-build:0.1.1?

It'd be nice to be able to verify with a hash.

Comment 1

3 years ago
If we worry about overwriting tags, we could always switch to pulling down by hash if we're using docker hub.  I believe funsize already pulls by hash.

Although in the case of testing out images on try that does make incremental development on the image a bit more cumbersome.
Yeah, there's definitely more room for improvement in the try process, automatically generating images, etc.  This would just be an aid to visibility of what I'm messing up now, and of what the improved process is getting right later.
Duplicate of this bug: 1208340
Whiteboard: [docker-worker]
Component: Docker-Worker → Worker
(Assignee)

Updated

6 months ago
Assignee: nobody → wcosta
Status: NEW → ASSIGNED
QA Contact: pmoore
(Assignee)

Comment 4

6 months ago
We use image hash now, closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.