Not all my desktop open tabs are synced to my iPhone (URL parsing?)

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: krudnitski, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

48 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
iPhone 6, iOS 8.4.1 running Build 43

'last synced' 3 minutes ago

* on my iPhone, I go to the 'cloud' panel 
* under my computer name, I run through all of the tabs but I'm not seeing www.hl.co.uk (exact address on my desktop is http://www.hl.co.uk/my-accounts/logout) and several others
* on my desktop, I have two firefox windows open: one with 19 tabs and one with 13 tabs 
... but on my phone, a total of 24 tabs are showing up (a mix from both desktop windows - no apparently rhyme or reason that I can see as to why some tabs aren't synced)
Tools > Sync Now on your desktop. Then pull-to-refresh on the tabs panel on the phone. Does that make a difference?
Flags: needinfo?(krudnitski)
(Reporter)

Comment 2

3 years ago
Desktop: one window has 16 tabs, the other has 13 for a total of 29. On the phone: 20 tabs are visible (mix between the two windows). There's definitely been some updates, but doesn't pull all my tabs over.
Flags: needinfo?(krudnitski)
Potential causes:

1. There are tabs on desktop that are dupes of each other or otherwise aren't syncable: fewer make it to the server.

2. The changed record is not being uploaded.

3. The changed record is not being downloaded.

4. There are tabs in the record that are not being applied to the local DB.


Open a browser console:


https://developer.mozilla.org/en-US/docs/Tools/Browser_Console


To test the first:


and run

    Weave.Service.engineManager.get("tabs")._store.getAllTabs().length

which should return a number. If that's 32, (1) is OK. If that's 24, then the desktop is at fault.



To test the second:

    Date(100 * (JSON.parse(Weave.Service.resource(Weave.Service.storageURL + "tabs/" + Weave.Service.clientsEngine.localID + "?full=1").get()).modified))

it'll return a date.
Flags: needinfo?(krudnitski)
(Reporter)

Comment 4

3 years ago
Ran Weave.Service.engineManager.get("tabs")._store.getAllTabs().length 

  and I got 23 (which is true) and just forced a 'sync now' on my mobile and I have 19 tabs there


I also just ran Date(100 * (JSON.parse(Weave.Service.resource(Weave.Service.storageURL + "tabs/" + Weave.Service.clientsEngine.localID + "?full=1").get()).modified)) 
 
  and I got "Fri Sep 04 2015 18:07:07 GMT+0100 (GMT Standard Time)" and on the phone in the cloud panel, it says 'last synced today at 18:04'
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #0)

> ... but on my phone, a total of 24 tabs are showing up (a mix from both
> desktop windows - no apparently rhyme or reason that I can see as to why
> some tabs aren't synced)

The answer to the ordering here is that they're sorted most-recently-viewed first.

As to why some tabs are missing, dunno! If you can get logs and/or your browser DB from the device, we can dig deeper.
Probably a URL parse issue.
tracking-fxios: ? → 1.1+
Summary: not all my desktop open tabs are synced to my iPhone → Not all my desktop open tabs are synced to my iPhone (URL parsing?)
Whiteboard: [might slip]
Assignee: nobody → etoop
Status: NEW → ASSIGNED
Created attachment 8667260 [details] [review]
Pull request

I've been unable to replicate any missing tabs even when using Karen's account so I have added logging to try and figure out under what circumstances tabs go missing.
Attachment #8667260 - Flags: review?(bnicholson)
Comment on attachment 8667260 [details] [review]
Pull request

Sorry for the delay -- looks fine to me!
Attachment #8667260 - Flags: review?(bnicholson) → review+
tracking-fxios: 1.1+ → 2.0+
Assignee: etoop → nobody
Status: ASSIGNED → NEW
tracking-fxios: 2.0+ → -
Whiteboard: [might slip]
Here's one possible explanation for this kind of thing: Bug 1250866.
Comment hidden (spam)
Comment on attachment 8757604 [details]
14.Insert.LargePlaylistBW.xml

Please don't set flags if you don't know what they are for.
Attachment #8757604 - Flags: sec-approval?
Attachment #8757604 - Attachment is obsolete: true
Attachment #8757604 - Flags: ui-review?
Attachment #8757604 - Flags: review?
:aaron - can you re-test this to see if this issue still exists.
Flags: needinfo?(aaron.train)
Priority: -- → P3

Updated

2 years ago
Flags: needinfo?(aaron.train) → needinfo?(catalin.suciu)
I'm not able to reproduce this issue following the steps from the description.
Tested on latest master running on iPad Air 2 (9.3.3), and Firefox release 48.0 on desktop

All tabs are correctly synced from desktop to device.

Karen, please reopen if you see this issue again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(catalin.suciu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.