contextmenu working in firefos os and hosted app does not as firefox packaged app

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: anaran, Unassigned)

Tracking

({regression})

43 Branch
regression

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150904030227

Steps to reproduce:

Tried to use context menu (right mouse key) in my app installed as Desktop Firefox App.



Actual results:

In Firefox OS nightly I get the expected context menu items.
Works as hosted app as well.

In the Desktop Firefox App a barely visible square appears in place of the menu with a small arrow in the lower right corner.

See no_menuitems


Expected results:

Desktop Firefox App should support context menu just like Firefox OS or hosted app.

See hosted_menuitems
(Reporter)

Comment 1

3 years ago
Created attachment 8657287 [details]
no_menuitems.png
(Reporter)

Comment 2

3 years ago
Created attachment 8657288 [details]
hosted_menuitems.png
Support for context menus in the webapp runtime was added in bug 776446.
Component: Untriaged → Webapp Runtime
Keywords: regression
(Reporter)

Comment 4

3 years ago
(In reply to Marco Castelluccio [:marco] from comment #3)
> Support for context menus in the webapp runtime was added in bug 776446.

Are you sure this is really fixed, considering bug 1157332 which already has another duplicate?
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157332
(In reply to Adrian Aichner [:anaran] from comment #4)
> (In reply to Marco Castelluccio [:marco] from comment #3)
> > Support for context menus in the webapp runtime was added in bug 776446.
> 
> Are you sure this is really fixed, considering bug 1157332 which already has
> another duplicate?

It used to work after bug 776446, but then it regressed. We could use mozregression to find a regression range.

I'm reopening this to track the regression, bug 1157332 will track adding some default options to the menu.
Status: RESOLVED → REOPENED
Keywords: regressionwindow-wanted
Resolution: DUPLICATE → ---
Can you give some STR for how to track this down with mozregression? I'm not very familiar with web apps.
Flags: needinfo?(mar.castelluccio)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #7)
> Can you give some STR for how to track this down with mozregression? I'm not
> very familiar with web apps.

You would need to install an app with a custom context menu and check that the custom context menu works.
Flags: needinfo?(mar.castelluccio)
Created attachment 8672031 [details]
asd.7z

Here's an example app, simply extract it somewhere, serve it (e.g. python -m SimpleHTTPServer), open it in Firefox and click on "install" to install it.
Thanks for the test app and STR :)

Regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82c90c17fc95&tochange=e3b76b155ca4

Too old to bisect on the integration branches, but bug 898647 seems like a likely candidate in that range.
Flags: needinfo?(mar.castelluccio)
Keywords: regressionwindow-wanted
Thank you!
I was expecting http://hg.mozilla.org/mozilla-central/rev/70fe31e4b65e, but it's newer than the regression range (this is definitely a cause of a further regression though, so that if we fixed the first, we'd still end up with broken context menus). Indeed, this changeset removed the PageMenu symbol from the EXPORTED_SYMBOLS of http://mxr.mozilla.org/mozilla-central/source/toolkit/modules/PageMenu.jsm.
Flags: needinfo?(mar.castelluccio)
Per bug 1238079, we're going to disable the desktop web runtime and remove it from the codebase, so we won't fix these bugs in it.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.