Make sure FxOS add-ons are not installable on Android or Desktop

RESOLVED DUPLICATE of bug 1221345

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED DUPLICATE of bug 1221345
2 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Points:
---
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.5+)

Details

(Reporter)

Description

2 years ago
Currently users can install fxos add-ons on desktop. We should not allow that. 

Two options:

a) Hide the Personalization category when not on FxOS platform
b) Show the category full of add-ons which cannot be installed

My vote is for option a.
Agreed. A.
Summary: Make sure FxOS add-ons are not installable on Android of Desktop → Make sure FxOS add-ons are not installable on Android or Desktop
We should hide "Addons" subcategory, not "Personalization" (since there are other subcategories that may apply to desktop/android)

Updated

2 years ago
Blocks: 1195470
No longer blocks: 1197020

Updated

2 years ago
Priority: -- → P2
mass-flag feature-b2g
feature-b2g: --- → 2.5+
In addition to hiding the link, we should disable the install button too. As mentioned in pivotal https://www.pivotaltracker.com/n/projects/1403820/stories/102773140 if that helps I can add `device_types: ['firefoxos']` to the API responses.

Updated

2 years ago
See Also: → bug 1208330
Bug 1208330 did most of this, its just the install button that needs disabling here.

Updated

2 years ago
Blocks: 1223121
No longer blocks: 1195470
Bug 1221345 takes care of the rest.
Depends on: 1221345, 1208330
If all is left is the button, then we can mark as a dupe of bug 1221345, which will indeed take care of that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221345
Add-ons (apparently) should work on Android just as on FxOS (but not on Desktop).
Resolution: DUPLICATE → INVALID
Sorry, sorry, sorry, my mistake.

I thought we were talking about b2gdroid, and we aren't. We're talking about NON-FxOS Android.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1221345
You need to log in before you can comment on or make changes to this bug.