The default bug view has changed. See this FAQ.

Multiple TEST-UNEXPECTED-FAIL | toolkit/components/search/*

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aleth, Assigned: florian)

Tracking

({intermittent-failure})

Trunk
Thunderbird 43.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Comment hidden (Treeherder Robot)

Comment 2

2 years ago
Looks like failure to read from resource://search-plugins/. 
Probably regression from Bug 1169459 <https://hg.mozilla.org/mozilla-central/rev/925475a10f08>
Florian, can you take a look at this one?
Flags: needinfo?(florian)
(Assignee)

Comment 4

2 years ago
Created attachment 8658285 [details] [diff] [review]
Patch

This ports the changes from bug 1162569, bug 1194265 and bug 1169459.

I'm not sure if this fully fixes the problem, but my try push seems slightly less busted (in the Windows 'X' runs) than the current trunk: https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=9e0efc010d3b
Assignee: nobody → florian
Flags: needinfo?(florian)
Attachment #8658285 - Flags: review?(Pidgeot18)
For those of you also not quite awake and expecting to see the try run when clicking on that link :)
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=1d16383d5958
(Assignee)

Comment 6

2 years ago
Some more context on the patch:
I was surprised that bug 1169459 caused failures for Thunderbird, as I had Thunderbird in mind when I made that patch. It turns out search was actually NOT broken in TB. It's just the tests that were broken, because for some reason http://mxr.mozilla.org/comm-central/source/mail/components/shell/DirectoryProvider.cpp is not loaded when running the toolkit xpcshell tests, but I figured updating TB to load engines in the same was as Firefox43 does wouldn't hurt, and would make it more future proof.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Attachment #8658285 - Flags: review?(Pidgeot18) → review+
Pushed to comm-central changeset 9184098a8ccc
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
You need to log in before you can comment on or make changes to this bug.