Crash displaying a message [@ BuildAttachmentList]

VERIFIED WORKSFORME

Status

MailNews Core
MIME
P1
normal
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: scottputterman, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla0.9.9
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Most recent crash is on 2002011503 on Win NT.

I've crashed randomly a number of times recently while displaying a message.  It
doesn't happen on the same message when I read it again.

Here are some talkback ids:

1711271 1462810 1442588 1201956

Here's the stack:

MSVCRT.dll + 0x2f52 (0x78002f52)
BuildAttachmentList [d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemoz2.cpp,
line 362]
MimeGetAttachmentList
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemoz2.cpp, line 528]
mime_display_stream_complete
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemoz2.cpp, line 893]
nsStreamConverter::OnStopRequest
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 1036]
nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 257]
nsStreamListenerTee::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 25]
nsOnStopRequestEvent0::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 321]
nsStreamListenerEvent0::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 122]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
(Reporter)

Updated

16 years ago
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9

Updated

16 years ago
QA Contact: esther → trix
(Assignee)

Comment 1

16 years ago
The first talkback report was with a Morning build from January 3rd.
(Assignee)

Comment 2

16 years ago
I am still not able to reproduce this problem :-(
(Reporter)

Comment 3

16 years ago
I haven't been able to reproduce this in a while and it was happening pretty
frequently before.  Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
verified wfm
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.