Not able to print iframe

RESOLVED DUPLICATE of bug 911444

Status

()

RESOLVED DUPLICATE of bug 911444
4 years ago
4 years ago

People

(Reporter: amolshetkar11, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

Steps to reproduce:

printing only iframe from webpage. But getting error on console as access denied to document 

code :
window.frames["iframe"].focus();
window.frames["iframe"].print();





Expected results:

should allow to print iframe from browser.

Comment 1

4 years ago
Could you attach a testcase, please.
Flags: needinfo?(amolshetkar11)
(Reporter)

Comment 2

4 years ago
(In reply to Aol11 from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML,
> like Gecko) Chrome/45.0.2454.85 Safari/537.36

 Steps to reproduce:

I have used IFrame to display the PDF and the PDF is located on same server. I have created print button and written javascript code to print iframe. But I received following error in console Error: Permission denied to access property "print" window.frames[iframeId].print();. But it is working fine on other browsers.
 
 javascript code :
 window.frames["iframe"].focus();
 window.frames["iframe"].print();

> 
> 
> 
> 
> Expected results:
> 
> should allow to print iframe from browser.
Flags: needinfo?(amolshetkar11)

Comment 3

4 years ago
We need the source code, just attach a minimal HTML file (you can attach to Bugzilla a sample PDF as resource on the same server) to reproduce the issue.
Flags: needinfo?(amolshetkar11)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(amolshetkar11)
Resolution: --- → DUPLICATE
Duplicate of bug: 911444
You need to log in before you can comment on or make changes to this bug.