Closed Bug 1202200 Opened 4 years ago Closed 3 years ago

Intermittent browser_social_chatwindowfocus.js | A promise chain failed to handle a rejection: - at chrome://mochitests/content/browser/browser/base/content/test/social/head.js:504 - ReferenceError: info is not defined

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: intermittent-failure)

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&group_state=expanded&fromchange=be8c33fb9849&filter-searchStr=Linux%20opt%20Mochitest%20Mochitest%20Browser%20Chrome%20M(bc1)

22:37:22     INFO -  213 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/social/browser_social_chatwindowfocus.js | A promise chain failed to handle a rejection:  - at chrome://mochitests/content/browser/browser/base/content/test/social/head.js:504 - ReferenceError: info is not defined
22:37:22     INFO -  Stack trace:
22:37:22     INFO -      makeChat/<@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:504:5
22:37:22     INFO -      Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934:23
22:37:22     INFO -      this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7
22:37:22     INFO -      Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:11
22:37:22     INFO -      this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:776:7
22:37:22     INFO -      this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:711:7
22:37:22     INFO -      DOMContentLoaded@chrome://browser/content/socialchat.xml:74:11
22:37:22     INFO -      EventListener.handleEvent*chatbox_XBL_Constructor@chrome://browser/content/socialchat.xml:69:1
22:37:22     INFO -      openChat@chrome://browser/content/socialchat.xml:603:11
22:37:22     INFO -      makeChat@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:500:17
22:37:22     INFO -      get3ChatsForCollapsing@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:453:1
22:37:22     INFO -      tests.testBrowserResize@chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_chatwindow_resize.js:49:5
22:37:22     INFO -      tests.testBrowserResizeMinimized@chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_chatwindow_resize.js:80:5
22:37:22     INFO -      runSocialTests/runNextTest/</<@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:208:11
22:37:22     INFO -      runSocialTests/cbPreTest@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:181:31
22:37:22     INFO -      runSocialTests/runNextTest/<@chrome://mochitests/content/browser/browser/base/content/test/social/head.js:204:7
22:37:22     INFO -      testScope/test_executeSoon/<.run@chrome://mochikit/content/browser-test.js:964:9
22:37:22     INFO -      testScope/test_finish/<@chrome://mochikit/content/browser-test.js:1062:11
22:37:22     INFO -      testScope/test_executeSoon/<.run@chrome://mochikit/content/browser-test.js:964:9
Duplicate of this bug: 1203932
test gone in bug 1289549
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(ryanvm)
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.