Closed Bug 1202208 Opened 6 years ago Closed 6 years ago

[Flame][FM Radio]After inserting the headset into device, FM Radio still can't work.

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S7 (18Sep)
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yi.zou, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(3 files)

[1.Description]:
[Flame KK v2.5][FM Radio] When headset is plugged into device, FM Radio can't work.
Found time:21:07.
See attachment:logcat_2107.txt, Flame KK v2.5.3gp.

[2.Testing Steps]: 
1.Tap the FM Radio app.
2. Insert the headset on a phone.

[3.Expected Result]: 
2.When headset is plugged into a phone, FM Radio can work normally.

[4.Actual Result]: 
2.When headset is plugged into a phone, FM Radio still can't work.

[5.Reproduction build]: 
Device: Flame KK 2.5 user (Affected)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.184109
Firmware Date          Sat Sep  5 18:41:21 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 eng(Affected)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Date          Sat Sep  5 18:38:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2(Unaffected)
Build ID               20150905032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d3cb4f28c735
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
2461

[8.Note]
FM Radio is incompletely on AriesKK v2.5 build.
Attached file logcat_2107.txt
Attached video Flame KK v2.5.3gp
QA Contact: yi.zou
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150903142425
Gaia Revision          679a3393136653ccdcc603ceb3b4918199f798e3
Gaia Date              2015-09-03 20:47:13
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/c71858609a870073f8891b62c4301559e80ca244
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150903144826
Gaia Revision          ea8866ae99d5e298dad43de4fc030e10f5ac16f2
Gaia Date              2015-09-03 20:59:03
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/2884c8122e5ac36247ed0820f6ccc3dd8ce5fdf6
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia-Rev        ea8866ae99d5e298dad43de4fc030e10f5ac16f2
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/c71858609a870073f8891b62c4301559e80ca244

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia-Rev        679a3393136653ccdcc603ceb3b4918199f798e3
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/2884c8122e5ac36247ed0820f6ccc3dd8ce5fdf6

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/679a3393136653ccdcc603ceb3b4918199f798e3...ea8866ae99d5e298dad43de4fc030e10f5ac16f2

Possibly caused by Bug 1156989.
QA Whiteboard: [MGSEI-Triage+]
Hi Hubert,

    This bug is probably caused by Bug 1156989, could you help to check?  

Thank you.
Flags: needinfo?(hub)
Reverted bug 1156989

https://github.com/mozilla-b2g/gaia/commit/6bba9182593d3e637cd950df160e96daf43664d9
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(hub)
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S7 (18Sep)
Duplicate of this bug: 1202732
This bug has been verified as "pass" on the latest build of Flame KK 2.5 by the STR in comment 0.

Actual results: When headset is plugged into a phone, FM Radio can work.
See attachment: verified_Flame KK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 eng(Pass)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185733
Firmware Date          Wed Sep  9 18:57:43 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 user(Pass)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185734
Firmware Date          Wed Sep  9 18:57:44 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.