Closed Bug 1202214 Opened 4 years ago Closed 4 years ago

Minimize, Maximize and Close buttons improperly themed in full screen mode on Windows 10

Categories

(Firefox :: Theme, defect)

40 Branch
x86
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 625312

People

(Reporter: admrlspeedy, Unassigned)

Details

Attachments

(1 file)

Attached image Controls.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Open Firefox.
Press F11 to enter full screen mode.
Move the cursor to the top right corner to drop down the navigation bar.


Actual results:

Vista/Aero-like window control buttons are shown rather than Windows 10 style buttons.


Expected results:

Proper Windows 10 controls should be shown.
Component: Untriaged → Theme
OS: Unspecified → Windows 10
Blocks: windows-10
Component: Theme → Widget: Win32
Product: Firefox → Core
Hardware: Unspecified → x86
This happens on Windows 8 as well, and I would swear we have this on file already, but I can't find anything better than bug 625312, so that's where it's gonna go.
No longer blocks: windows-10
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Widget: Win32 → Theme
Product: Core → Firefox
Resolution: --- → DUPLICATE
Duplicate of bug: 625312
(In reply to :Gijs Kruitbosch from comment #1)
> This happens on Windows 8 as well, and I would swear we have this on file
> already, but I can't find anything better than bug 625312, so that's where
> it's gonna go.
> 
> *** This bug has been marked as a duplicate of bug 625312 ***

I guess I never noticed it on Windows 8. I don't use full screen but I pressed F11 by accident one day and noticed this.
You need to log in before you can comment on or make changes to this bug.